Character encoding problem

Asked by Birdy on 2010-02-12

Please look at:

 http://www.it.uu.se/edu/course/homepage/simopsyst/p2ht09

When I look at this web location with Microsoft Explorer 8 the page looks fine. I designed this page for my course and I have no problems in viewing it. In the beginning of the page if one looks at the source, there is,

 charset=iso-8859-1

And in Microsoft Explorer 8 with the following settings

   View -> Encoding

I have Auto-Select checked.

This works as I expect and shows the page correctly!

However, when I use Ubuntu 9.10 with Firefox 3.5.7 I have been unable to find any setting for character encoding that will display this page when I open it!

I would appreciate greatly information on how to set up my Firefox to view my homepage when it is opened.

Thank you,
--V

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu firefox-3.5 Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Birdy (vs) said : #1

I have saved a *.png image of what I see when I connect to my homepage. How can I get this image to you?

delance (olivier-delance) said : #2

Display->Encoding->Unicode(UTF16)

Sam_ (and-sam) said : #3

You may upload it to your favourite image host page and post the link here.
Firefox encoding = automatic, for example Launchpad has UTF-8, your page ISO-8859-1.
Your page looks like this from here
http://www4.pic-upload.de/12.02.10/ktiyjabnzv52.png

Maybe have a look at W3C.
http://en.wikipedia.org/wiki/World_Wide_Web_Consortium
http://www.w3schools.com/

Sam_ (and-sam) said : #4

Thanks to delance, confirm UTF-16 works.

Birdy (vs) said : #5

My image looks the same as what you have given in your answer.
I have looked at the URLs that you suggested --- unfortunately, I do not understand how they answer my problem.
The problem seems to be that Firefox is not really doing auto-detect.

How do I force auto-detect in Firefox? I have tried to click the off button but it always returns to Off!

--V

Sam_ (and-sam) said : #6

> Firefox is not really doing auto-detect
Don't agree, except your page, it does detect all other pages, or do you have another example?
These are very well auto-detected (ISO-8859-1)
http://www.it.uu.se/edu/
http://www.it.uu.se/edu/course/
http://www.it.uu.se/edu/search

> I designed this page for my course
that's why I've linked to W3C standards.

Can you help with this problem?

Provide an answer of your own, or ask Birdy for more information if necessary.

To post a message you must log in.