User Agent says it's MSIE ?!

Asked by Adilson Mohr on 2010-02-10

I everybody !

It's been a while since I am fighting with Yahoo Mail to work well with Shiretoko... I always thought it was about that Shiretoko/Firefox thing that a lot of people are complaining about. I've tried a lot of modifications in the about:config user agent and in the Firefox files, with no sucess - but today I found something new.

Browsing around, I saw that my user agent is been discoreved as :

HTTP USER AGENT header Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
Browser branch name IE 5.5
Browser name IE
Browser version 5.5
Platform Win98
Operation System Windows 98
Browser full name MSIE 5.5

But that is not correct ! The Help -> About Firefox says :
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.7) Gecko/20100106 Ubuntu/9.04 (jaunty) Firefox/3.5.7

The about:config is like default:
general.useragent.extra.firefox Firefox/3.5.7
general.useragent.locale en-US
general.useragent.security U
general.useragent.vendor Ubuntu
general.useragent.vendorComment jaunty
general.useragent.vendorSub 9.04

I didn't want to open a bug, as I didn't find anyone else with this problem - and I have the same problem with Firefox 3.0... Looks like something with my Ubuntu, instead of with Firefox/Shiretoko... as far as I remember, it started when I installed Jaunty...

Does anyone knows what can it be ?!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox-3.5 Edit question
Assignee:
No assignee Edit question
Solved by:
Adilson Mohr
Solved:
Last query:
Last reply:
Adilson Mohr (adi-mohr) said : #1

Well, the problem is with ntlmaps... I don't know why, but when I disabled it, the UA started to look ok :

HTTP USER AGENT header Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.7) Gecko/20100106 Ubuntu/9.04 (jaunty) Firefox/3.5.7.

Please, add a comment if you know why this happens...

Anyway, that didn't made Yahoo work correctly :-/

(thanks to programad from http://ubuntuforums.org, to point the direction - http://ubuntuforums.org/showthread.php?p=8814643#post8814643)

Adilson Mohr (adi-mohr) said : #2

Well, now Yahoo Mail is working - I didn't see that the error message has changed to something like "not tested in your OS, take your chances". Hit ok and it's working as usual :)