Ubuntu

Why is Firefox so slow in Ubuntu?

Asked by Márcio Vinícius on 2007-07-08

Can someone tell me why Firefox is more slown in Ubuntu than in Windows?

Try to scroll this page: http://peixenarede.blogspot.com This is my blog. The semi-transparent background I put in posts' area (made with a PNG dot), makes the page very heavy in Firefox in Ubuntu. The same thing doesn't happen with Opera in Ubuntu or with Firefox in Windows (with the same hardware).

The problem is in Firefox of Ubuntu (or Linux in general). Why does it happens? How can I solve this problem (or at least minimize it)? I already tryed to use Firefox download from mozilla's site, and it still has a poor performance.

Is Firefox for Linux different from Firefox for Windows? Why?

It's very baffling...

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu firefox-3.0 Edit question
Assignee:
No assignee Edit question
Last query:
2008-08-19
Last reply:
2009-01-30
gul (rawal6) said : #1

Dear Marcio! My Firefox is working like lightning, perhaps you should upgrade it through synaptic manager and remove unnecessary extensions.

My Ubuntu is fully upgraded and updated. This problem happens even in a new intallation of Firefox (with no extensions or plugins). And it is a known problem. I think the problem is in the redering method of Firefox in Linux. There is a lot of threads in Ubuntu Forum reporting it (i.e. this one http://ubuntuforums.org/showthread.php?p=2989627 ). I just want to known why does it happen.

Darrin Tisdale (tizzyd) said : #3

I see the same thing you do, Marcio. Firefox renders pages very slowly, and I have a P4 with 2GB RAM. Downloading extensions require about 1 minute delay, something that the Firefox app on my MacBook Pro sitting right beside--and using the same wireless connection--zips through with no issues. So, there's got to be something going on. I don't have any other UI issues, and in fact, the system is quite responses...save for Firefox. But then, since I have moved all my office functions to Web apps, it's fairly important to have a responsive UI in my web browser.

I'm going to try Swiftfox as well as the Pango fix, and I'll report back if I see improvements.

ok.

Darrin Tisdale (tizzyd) said : #5

Testing with Swiftfox shows some improvements.

Testing with the alternate rendering method described in previous threads did not demonstrably improve rendering.

Moreover, I can easily demonstrate the differences between the platforms installing an extension. In a VM on the same box, response from the installation site happens within 1 second. Response takes sometimes several minutes from the Ubuntu installation. There is no reason for the disparity that I can isolate.

ashwin_kumar96 (ashwinkumar96) said : #6

hi ,its simple, firefox in ubuntu by default tries to use ip v6, which may not be supported by many networks, hence open firefox, type about:config and type ip in the filter box and search for network.dns.disable and double click it, restart ur firefox, thats all about it

Ashwin

My friend gul,

I always keep my Firefox uptodate! The problem happens with or without extensions...

And doesn't happen only to me.

See the bugzilla post:
https://bugzilla.mozilla.org/show_bug.cgi?id=90198#c218

I realized that some site uses huge CPU procesing with no apparent reason. It doesn't happen with Opera in Ubuntu or Firefox (or Opera or Internet Explorer) in Windows.

pclinux (pclinux) said : #8

If you're using an NVIDIA graphics, there are serious performance issue with the Linux drivers. Firefox scrolling is slow on certain website.
http://www.nvnews.net/vbulletin/showthread.php?t=115916

Yes, it is exactly the case...

but can we do about it?

i'll take a look at the topic you pointed...

thanks, pclinux!

Launchpad Janitor (janitor) said : #10

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

last message didn't answer my question, since the problem doesn't have relation only to nvidia drivers...

once again, see the bugzilla post: https://bugzilla.mozilla.org/show_bug.cgi?id=90198

I think is related to flash rendering i have this issue when pages show me flash embedded videos in it.

http://stas.nerd.ro/blog/index.php/2008/05/09/make-adobe-flash-faster-on-ubuntulinux/

Hope this help

gypsy_roadhog (neil-turner) said : #13

I'm running firefox 3.0.5 on Ubuntu 8.10.

Ashwin's IP fix works fine for me but I wonder why we're still shipping with a default that causes problems.

houdelou (houdelou) said : #14

Thank you ashwin_kumar96. Your solution worked like a charm. I was wondering why Firefox was so slow !

Hi Marcio. I experienced the same problemand tried several fixes, including some of those posted here. None worked.

I ended up switching to Google Chrome, which is very fast and, in my opinion, a better browser.

DrivenOG (drivenog) said : #16

Just wanted to reply to ashwin_kumar96 said on 2008-05-07 post " by default tries to use ip v6, . . .type about:config and type ip in the filter box and search for network.dns.disable and double click it, restart ur firefox, ". Thank you Ashwin for the easy to follow tip, it worked great. One thing to add is the normal state is :"False" so turning it to "True" gave me a slight pause but it worked and now Firefox loads seemingly effortlessly ... yippeee !..

Can you help with this problem?

Provide an answer of your own, or ask Márcio Vinícius for more information if necessary.

To post a message you must log in.