Getting flash to work in Firefox

Asked by RedRat

OK, I had to remove firefox from my 8.04 Hardy installation since it would not start. I reinstalled Firefox 3 from Synaptic. I also installed Adobe Flash player from Synaptic. When I visit YouTube I get this message:
"Hello, you either have JavaScript turned off or an old version of Adobe's Flash Player. Get the latest Flash player."

I have also installed and downloaded the unrestricted mozilla addons. I have gone through just about all of the various suggestions about flash and ff, to no avail. Any ideas.

Question information

English Edit question
Ubuntu firefox-3.0 Edit question
No assignee Edit question
Solved by:
Kevin Hunter
Last query:
Last reply:
Revision history for this message
Kevin Hunter (hunteke) said :

I now use Jaunty on my system, so I can't personally verify this information. That said, Bug #304969 suggests that if you install the 'swfdec-mozilla' package, you can at least watch videos on Youtube.

Revision history for this message
RedRat (jwekell) said :

I not only installed that package but also the gnash package. since I have Flash player installed and have turned on Java script under Edit>Preferences>Content, I don't understand why it doesn't show the videos. This is very strange.

Revision history for this message
Kevin Hunter (hunteke) said :

1. I'm sorry this isn't working. I'd like to say Linux is 100% easy to use, but clearly we aren't there yet.

2. I hate to suggest this, but you might try removing all but the package you're testing. So, if you're testing swfdec-mozilla, remove Gnash.

3. Failing that, you might step outside of the package manager's understanding of what Flash is, and install directly from Adobe:

4. Failing all that, you might consider upgrading to a more recent version of Ubuntu. Hardy is an LTS system, but I've been very much appreciating Jaunty's stability. (Unfortunately, the next LTS from Ubuntu isn't schedule until next year's October.)

Revision history for this message
RedRat (jwekell) said :

I tried installing it from the Adobe site, since this is where YouTube pointed me. I did download and tried that too and I still got that message that it wasn't seeing flashplayer. then I tried it from Synaptic.

What about the following to try:
1. uninstall Adobe FlashPlayer from Synaptic, complete removal.
2. then go to terminal and try sudo apt-get install adobe-flashplayer

Would this do anything that new?

Revision history for this message
Kevin Hunter (hunteke) said :

No, what I got from the bug report I mentioned earlier is that the repository's version of flash is borked.

My instinct is to make sure that you really have installed the plugin and that Firefox can see it. I haven't installed flash from Adobe's installer in quite a long time, but I believe the file for which you're looking is Or perhaps

When you've found it, make a symlink to it from the .mozilla/plugins directory.

$ find / -name '*"
  [ ... will probably take a few minutes; it's searching your hard drive ... ]

$ cd ~/.mozilla/plugins
$ ln -s /path/to/libflashplayer/wrapper

Then restart Firefox.

Revision history for this message
Kevin Hunter (hunteke) said :

Another thought: see what plugins Firefox *is* loading.

Firefox→New Tab→URL: about:plugins

Revision history for this message
RedRat (jwekell) said :

Ok when I go to about:plugins the only plugin playing flash is this:
Shockwave Flash

    File name:
    Shockwave Flash 10.0 r32

MIME Type Description Suffixes Enabled
application/x-shockwave-flash Shockwave Flash swf Yes
application/futuresplash FutureSplash Player spl Yes

I do not see any Adobe Flash other than this one.

How about if I do as I said before, remove Adobe Flashplayer with Synaptic, then go to the Adobe site and allow Adobe installer to install that version, although the version number is the same as in Synaptic.

Revision history for this message
Best Kevin Hunter (hunteke) said :

Try it and see?

Revision history for this message
Kevin Hunter (hunteke) said :

Hmm. I note that your's says '' while mine says ''

That may be an issue. Or it may be a red herring: I'm running 64-bit Ubuntu.

Revision history for this message
RedRat (jwekell) said :

Thanks Kevin Hunter, that solved my question.

Revision history for this message
Kevin Hunter (hunteke) said :

Good deal.