cannot watch online video on hulu

Asked by Dave on 2009-01-17

I can watch most youtube videos, but videos on hulu.com or nbc.com do not play. On hulu, the "loading video" screen appears, but the video never loads. On nbc.com the screen is white where the video should be. In either case if I right-click on the video I get a Gnash menu, but the movies won't play. My version of Gnash is LNX 9,0,999,0. I have installed every shockwave flash plugin I could find, but still can't get these sites to play videos using firefox. Flash games are hit and miss, but that's not a big deal. I am running ubuntu 8.10. I'd appreciate any help with this issue, since this is one of the very few things I am trying to use this computer for.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox-3.0 Edit question
Assignee:
No assignee Edit question
Solved by:
nhasian
Solved:
2009-01-17
Last query:
2009-01-17
Last reply:
2009-01-17
Hemanth (hemanth-hm) said : #1

Type on after other in terminal

$ wget http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz

$ tar xvfz install_flash_player_9_linux

$ cd install_flash_player_9_linux

$ ./flashplayer-installer

Now, check about:plugins , do you find flash , are you able to watch in hulu?

Hemanth (hemanth-hm) said : #2

If that didn't help , this will for sure :

$ sudo apt-get install flashplugin-nonfree
$ sudo apt-get remove gnash

Dave (bostwick3000) said : #3

Thanks for your quick response. Method 1 generated a 404 error after the first entry

Method 2 did remove Gnash, but did not enable the videos to play. Now on hulu I get a black screen - no "loading video" appears as it did before. On nbc.com I first got a silver circle with a triangle in the center where the video should be. After clicking it, the portion of the screen in which the video should display goes black. Rebooting did not change this.

Dave (bostwick3000) said : #4

about:plugins indicates I have libswfdecmozilla.so Shockwave Flash 9.0 r999 enabled. I also have Totem Web Browser Plugin 2.24.3 enabled, which has an entry for flash video/flv. Thanks again for your help; I really appreciate it.

Dave (bostwick3000) said : #5

I'm not sure if this is useful info or not, but now youtube videos don't play at all. They either cause firefox to crash or they display "Please wait. Loading video" forever. Prior to entering the commands, the ones that now take forever to load would play and the ones that now crash FF just wouldn't load.

Thanks again for your help.

Best nhasian (nhasian) said : #6

lets try fixing your flash. go to System->administration->synaptic package manager. search for flash. do a complete removal of all flash packages like flash 9, flash 10, gnash, swfdec. now when you launch firefox and type about:plugins in the url it should no longer show anything installed for flash.

In the past, if you had installed flash manually from adobe's website then you'll need to delete the file libflashplayer.so manually. usually in /usr/lib/firefox/plugins you can also find it with the command:

locate libflashplayer.so

now you can simply install flashplugin-nonfree either from the synaptic package manager or from the terminal with the command:

sudo apt-get install flashplugin-nonfree

let me know if that fixes your flash issue.

Dave (bostwick3000) said : #7

It's working just fine now. Thank you so much for your help, both of you. I really appreciate that you would take the time to help me with this.

Dave (bostwick3000) said : #8

Thanks nhasian, that solved my question.

I have did what nhasin said, but I still get just a black screen on hulu.com

Youtube works fine.. everything was working yesterday, and then when re-booted this morning it was broke... hmm..

about:plugins
Shockwave Flash
    File name: libswfdecmozilla.so
    Shockwave Flash 9.0 r999
MIME Type Description Suffixes Enabled
application/x-shockwave-flash Adobe Flash movie swf Yes
application/futuresplash FutureSplash movie spl Yes

laneyvongrimm (laneyvongrimm) said : #10

I am having the same problem mrkaraokesteve is having. i uninstalled flash and reinstalled, but nothing changed. i didnt have any problems with my computer before this huge update around april 22. i only see a black screen on hulu and a silver play button everywhere else. can someone please help?

I tried the suggestion by nhasian, all I get now on hulu screen is a message to download amd install flashplayer? now what?

@<email address hidden>

Please don't append a new question on a already answered or marked as solved question.
Please make new question from here: https://answers.launchpad.net/ubuntu/+addquestion
you will get better chance to get right answer on a fresh tagged "open" question.
Solved or answered questions are usually not read from answering people.

Thank you