Tabs and Proxies

Asked by U N Gaitonde on 2009-01-02

I have noticed this irritant.
I am in a place where we have to use a proxy server.
And, after starting Firefox, if I open a set of multiple tabs from the bookmarks toolbar, Firefox prompts for the proxy login+password for each tab. Since I use 'remember passwords' and also a master password, it opts for the master password also. So, if there are five tabs to be opened, then after clicking 'Open all in tabs', I get 10 prompts. Five for the master password, and five for the proxy-login-password. I have noticed that filling in the master password once is sufficient, but I have to hit enter or click on 'OK' ten times!
Can this irritant be removed?

However, once a proxy is provided (and accepted), then opening further tabs does not lead to any prompts.

I would prefer that even when the request is for opening of multiple tabs in one go, Firefox should ask for the master password and the proxy-login-password just once.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu firefox-3.0 Edit question
Assignee:
No assignee Edit question
Last query:
2009-01-17
Last reply:
2009-01-16
Gergely Máté (sportember) said : #1

It may be because of bad proxy setup, as proxy login should not be requested in a browser window. Can you ask someone to set up the proxy is a more friendly way?

U N Gaitonde (gaitondeun) said : #2

The http_proxy has been set, and that setting is picked up by all other stuff (e.g. synaptic).
However, Firefox (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.10 (intrepid) Firefox/3.0.5) does not pick it up.

I agree with you on proxy settings of Firefox i have sent (more then 4 years ago) a request to Firefox team to solve this issue...
http://forums.mozillazine.org/viewtopic.php?f=8&t=326089

Try to set the proxy from the menu System→Preferences→Network Proxy

Then open Firefox and tell him to use it, from menu:

Edit→Preferences→Advanced→ [ Network tab ]

search Connection press "Settings" button

and select the radiobox "Use System proxy settings"

Hope this helps

I have linked this question to the https://bugs.launchpad.net/ubuntu/+source/firefox-3.0/+bug/195698 so we are can automatically notified if something will change.

Thank you

U N Gaitonde (gaitondeun) said : #5

I tried the stuff recommended.
Most of it was already in place.
However, I am still being prompted for proxy!

So, this is a stalemate, for now!

Can you help with this problem?

Provide an answer of your own, or ask U N Gaitonde for more information if necessary.

To post a message you must log in.