Ubuntu

Firefox for Ubuntu Canonical does not display images at some pages

Asked by Pham Thanh Nam on 2008-12-24

Binary package hint: firefox-3.0

I use Firefox 3.0.5 (version for Ubuntu Canonical - 1.0) on Ubuntu 8.10
I need to access http://www.avermedia.com/ to find information about TV cards, but this page is not displayed correctly (without images). Firefox 3.0.5 (is not version for Ubuntu Canonical) on Ubuntu 8.04 still displays this page correctly.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: hsfengine wl
Package: firefox-3.0 3.0.5+nobinonly-0ubuntu0.8.10.1
ProcEnviron:
 LANGUAGE=vi_VN:vi:en_GB:en
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=vi_VN
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.27-9-generic i686

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox-3.0 Edit question
Assignee:
No assignee Edit question
Solved by:
Pham Thanh Nam
Solved:
2008-12-26
Last query:
2008-12-26
Last reply:
2008-12-25
Pham Thanh Nam (alophone2003) said : #1

Thanks for taking the time to report this. However, I think this isn't really a bug, it's rather a question.
The site uses flash, it's possible you don't have flash installed yet. To install flash:
Go to "Applications"->"Add/Remove..." and search for "flash".
You can either install the "Macromedia Flash Plugin" or "Ubuntu restricted extras"(this gives support for mp3, avi, mpeg, truetype, java and flash)
I hope this has solved your problem!

Open a Terminal from the menu Applications → Accessories → Terminal and type:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

sudo apt-get install flashplugin-nonfree

sudo apt-get clean

give your user password when requested, you don't see nothing when you type it, then press enter.

If you have some trouble with sound you can also install the libflashsupport
then open a Terminal from the menu Applications → Accessories → Terminal and type:

sudo apt-get update
sudo apt-get install libflashsupport

Due poor integration of proprietary flash with Linux you may want to install also the mozilla plugin Flashblock
to block flash into web pages to get better Firefox and general pc performance
you may install it using mozilla here: http://flashblock.mozdev.org/installation1.html

If this solves you problem, please mark as Solved. If not, please clarify your question.

Hope this helps

Pham Thanh Nam (alophone2003) said : #4

No, the things missing ain't flash. I've already installed flash plugin and flash is still displayed correctly. The things missing are really JPG images. By using Firefox 3.0.5 (not version for Ubuntu Canonical) on Ubuntu 8.04/Windows or Konqueror, I can still see and save these images.
On the homepage of that site, there is a long flash banner stretching over the browser window (displayed correctly). Under that flash banner, there are 6 JPG images correspondent with Entertainment, Presentation, Surveillance and 3 product images of each category (not displayed on Firefox 3.0.5 for Ubuntu Canonical).
By clicking or opening for example http://www.avermedia.com/avertv/ in another browser, I still see many product images, but I can't see any image on that site in Firefox 3.0.5 for Ubuntu Canonical.

Pham Thanh Nam (alophone2003) said : #5

Oh, sorry. I've found that I activated accidentally "Block images" on that site.
Problem solved. Thanks anyway.