embeded audio ssl

Asked by John Doe on 2008-04-21

Binary package hint: firefox-3.0

1.) Release: Ubuntu Hardy 8.04
2.) Version: 3.0b5
3. & 4.) Firefox fails to play embedded audio in html on SSL/HTTPS pages.

I ran the following HTML code on an HTTP and HTTPS server, and the audio ONLY played on the HTTP:

<html>
<head><title></title></head>
<body>
<embed src="bach-pachelbel_in_D.wav" autostart="true">
</body>
</html>

I assume this bug exists with the gopher protocol as well.

Half the time the above webpage crashed immediately on SSL/HTTPS, the other half it didn't. I tried to run Firefox in terminal with Firefox --debug, but that is not a valid flag.

ProblemType: Bug
Architecture: i386
Date: Mon Apr 21 06:37:17 2008
DistroRelease: Ubuntu 8.04
Package: firefox-3.0 3.0~b5+nobinonly-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.24-16-generic i686

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu firefox-3.0 Edit question
Assignee:
No assignee Edit question
Last query:
2008-09-17
Last reply:
2008-09-17

This question was originally filed as bug #220115.

John Doe (johndoe32102002) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs .

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

John Doe (johndoe32102002) said : #4

On 9/12/08, Launchpad Janitor <email address hidden> wrote:
> Your question #43413 on firefox-3.0 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/firefox-3.0/+question/43413
>
> Status: Open => Expired
>
> Launchpad Janitor expired the question:
> This question was expired because it remained in the 'Open' state
> without activity for the last 15 days.
>
> --
> If you're still having this problem, you can reopen your question either
> by replying to this email or by going to the following page and
> entering more information about your problem:
> https://answers.launchpad.net/ubuntu/+source/firefox-3.0/+question/43413
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
PGP Public Encryption Key:
http://johndoe32102002.blogspot.com/

First be sure all audio mixer volume cursors are on and to 80% of volume, check it by doubleclick on top right loudspeaker icon a mixer come in front of you.

And try...

If this doesn't solve your issue... try to:

Clean firefox mozilla profile

Close all opened Firefox and try to delete your Firefox user setting open a terminal from applications->Accessories->Terminal and type:
mv .mozilla .mozilla_old
and restart Firefox.

If you have a lot of bookmarks please export them before move your setting directory, then import them again from saved file into Firefox.
Also take note of your installed Firefox extensions, to reinstall them.

if this works then delete the .mozilla_old directory, from terminal, type:
rm -fr .mozilla_old

hope this helps

Can you help with this problem?

Provide an answer of your own, or ask John Doe for more information if necessary.

To post a message you must log in.