My no sound with youtube woes

Asked by kiwipete on 2008-08-05

Ok, here is my delima.
I posted in this forum and was advised to do a separate post here. https://answers.launchpad.net/ubuntu/+source/firefox-3.0/+question/34735

I have an Asus A6U laptop which is dedicated to Hardy Heron.
The SIS SI702, USB Audio, OSS Open Sound System, PulseAudio Sound Driver sound drivers work on the laptop only.
However when I try a test of the ALSA Advanced Linux Sound Architecture driver I get this error, audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Could not open audio device for playback.

My major problem is that no matter what Ive tried, I cannot hear sound when watching youtuve video from within youtube using Firefox.
All other video works fine when watched off the hard drive.
I wonder if there is some kind of audio drivers I may need to look for , for this Laptop?
I just don't know enough about Ubuntu yet to fault find by myself, so any help and ideas would be kindly accepted thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu firefox-3.0 Edit question
Assignee:
No assignee Edit question
Last query:
2008-08-20
Last reply:
2009-12-13
Massimo Forti (slackwarelife) said : #1

Thanks to contact us, I did a search and I found this:

https://bugs.edge.launchpad.net/ubuntu/+bug/200451

Can you tell us what version of ubuntu uses (kenrel version)

Thanks many

kiwipete (prboyce) said : #2

Im using Hardy Heron, but how do I find the version number?

Massimo Forti (slackwarelife) said : #3

thanks,
you have a 8.04 ubuntu version. If you have done all update you have the 2.6.24-20-generic kernel version (to know your right version of kernel open a shell and write "uname -r").

Now I want to know you sound device (you have a pci device, right).

Open a shell and write "lspci" and post the result.

Thanks many.

kiwipete (prboyce) said : #4

2.6.24-20-generic
This is indeed the version I have.
OK here goes the entire list for lspci........

kiwipete@Ubuntu-laptop:~$ lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 760/M760 Host (rev 03)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] (rev 36)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:09.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
00:0a.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
00:0a.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
00:0a.2 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 04)
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter

Howdy,

I ran into the same problems, and fixed it by following the instructions in this forum:

http://ubuntuforums.org/showthread.php?t=75237

However, I recently read about a known issue with flash that's fixed by installing the libflashsupport package available from the repositories. I haven't tested it, but it might be worth a shot. I found that little tidbit at http://www.derekhildreth.com/blog/how-to-fix-the-no-sound-issue-in-firefox-flash/ and then searched for the package in Synaptic. It looks like it's a fix specifically for PulseAudio.

I hope this helps...

Michael

kiwipete (prboyce) said : #6

Thanks for the links Michael, but this has not helped me. I still have no sound.
I am wondering what setting I should be using and could this be a cause of the problem, when I go to the Firefox Preferences / Applications section for the different actions etc?

When I looked in the Firefox settings, I didn't solve anything. I had to manually edit the firefoxrc file and change the FIREFOX_DSP setting to auto, e.g.

FIREFOX_DSP="auto"

after installing esd.

Did you try the libflashsupport plugin? I have to admit I was very curious as to whether that would work or not.

Michael

kiwipete (prboyce) said : #8

Ye I already had the libflashsupport plugin installed..............

kiwipete (prboyce) said : #9

I think I will erase everything reinstall My Hardy Heron as I have no sound what so ever now.
It was working fine this morning when I took the laptop to work, but when I came home and plugged it all back in and re-powerd it, there is no sound peroid!
If I stil lcannot get sound working properly, I will have to resort to crappy old M$ again. Humph.

Be also be sure your system is fully upgraded, to check:
open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get clean all
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get clean all
sud apt-get autoremove

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

kiwipete (prboyce) said : #11

I ran this command (sudo apt-get update) and got the following error.

"Problem during package list update. The package list update failed with a authentication failure. This usually happens behind a network proxy server. Please try to click on the "Run this action now" button to correct the problem or update the list manually by running Update Manager and clicking on "Check"."

When I followed the prompt from the "Run this action now" box, I get this error.

W: GPG error: http://falcon.landure.fr hardy Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 1CA3E3239FA7DC39

Harold (hbar12) said : #12

You might try updating to Ubuntu 8.10 and then 9.04 and even 9.10, although I like 9.04 better so far. Any ugrade might have your drivers. I would think especially the newer ones or older ones if you have an older computer, i don't know. I sure like the easier solutions.

Can you help with this problem?

Provide an answer of your own, or ask kiwipete for more information if necessary.

To post a message you must log in.