firefox-3.0 bug

Asked by swinfi2 on 2008-06-27

when i double click my firefox icon it starts with no bookmarks but it is fixed by running "sudo firefox-3.0" and my password i don't want to tell everyone using the computer the password and its annoying not having any bookmarks and or the person who i run it for might close the terminal and firefox by closing the terminal without realizing.

firefox 3
ubuntu 8.04

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox-3.0 Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2008-06-29
Last query:
2008-06-29
Last reply:
2008-06-27
Jensen Somers (jsomers) said : #1

By using the "sudo" command you are running Firefox as root, thus all the bookmarks and settings will be saved in the configuration directory of the "root" user in stead of your "local" user. You should be able to export the bookmarks of the "root" user and import them when running Firefox as your "local" user.

Try changing the owner of .mozilla/firefox directory

Please open a Terminal from the menu Applications->Accessories->Terminal and type or better copy and paste one row a time:

export myuser=$(who am i | cut -d " " -f 1)
sudo chown -R $myuser.$myuser /home/$myuser/.mozilla/firefox

Hope this helps

swinfi2 (swinfi2) said : #3

thanks that solved it bot i had to chande the second line to

sudo chown -R $myuser /home/$myuser/.mozilla/firefox

swinfi2 (swinfi2) said : #4

Thanks marcobra, that solved my question.

Guanajuato (ubuntu-guanajuato) said : #5

I'd just like to say that I also had this problem.
Checking the folder and file properties, the user was reported as correct user. However, marcobra's suggestiong fixed the problem.

Thanks.