Firefox starts up in fullscreen mode

Asked by mtchaze on 2008-05-26

Am using Firefox 3.0b5 on Ubuntu 8.04. The browser starts up in full screen mode every time. I reset using F11.
How do I get it back to standard mode?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu firefox-3.0 Edit question
Assignee:
No assignee Edit question
Last query:
2008-05-26
Last reply:
2009-04-20
mtchaze (mtc-os) said : #1

When the browser starts up in 'FULL' screen mode, there are no minimise, maximise or X icons in the top right hand corner.

Knut Karevoll (gnonthgol) said : #2

You can toggle fullscreen mode with F11.
Check about:config in firefox to see if you find a setting that might explain the startup behavour. To flush your config you can delete ~/.mozilla THIS WILL EMULATE A FRESH INSTALL OF FIREFOX.

Is metacity running? Or is Compiz enable?

--
BUGabundo :o)
(``-_-ยดยด) http://Ubuntu.BUGabundo.net
Linux user #443786 GPG key 1024D/A1784EBB
My new micro-blog @ http://BUGabundo.net
ps. My emails tend to sound authority and aggressive. I'm sorry in advance. I'll try to be more assertive as time goes by...

ideefixe (ivan-babkin) said : #4

Probably I have the same problem with compiz enabled. This isnt happening every time I start firefox, but only sometimes.

This is not true firefox's fullscreen mode (the one you toggle with F11 by default); it more looks like compiz (as WM) is starting the browser's window fullscreen: there is a menu (File, Edit etc) but there are no minimize/maximize/close buttons in the top-right.

wc.000123 (wc-000123) said : #5

The problem is similar to Internet Explorer's where it doesn't remember the screen size unless you physically drag and resize it. When I did F11 the first time, all subsequent Firefox sessions launched in full screen mode doesn't matter if I did F11 to shrink it down then close the session. Then I remembered the XP trick so I tried it and it worked.

If the screen were stuck in full screem, then F11 to get to the normal window. Then right click on the maximize button and select unmaximize. Then physically drag and resize the window. Now that should change the window configuration so next time it will not launch in full screen mode by default.

Steve Stringer (dksteve) said : #6

If you have the same problem I just had it is not that firefox starts in full mode - but it does look similar. I'm not sure why the issue happened, but it looked like corrupt preferences file or something like that. Anyway try this. Start firefox in safe mode from the command line.

firefox -safe-mode

Select "Reset toolbars and controls" then click Continue in Safe Mode.

This should fix it :o)

Scott Wegner (swegner) said : #7

I'm having this issue as well. Starting Firefox in safe-mode and resetting toolbars, as suggested by Steve, only fixed things temporarily for me. Starting Firefox regularly again brought back the issue.

I saw a blog post which suggests a workaround setting some window behaviour preferences in CCSM [1]. I haven't tried is, as I don't have CCSM installed (and would rather not install it if I don't need to). I suspect disabling Compiz altogether may also fix things, but that also seems like a last-resort workaround.

Anybody else having this problem? This is on a Toshiba laptop running Ubuntu Intrepid x86 w/ Firefox 3.0.4, default ATI video driver, with compiz & metacity compositing.

P.S., this should be a bug report, not a "question", right? Can we convert it easily?

Scott Wegner (swegner) said : #8

Sorry, forgot to add link to CCSM workaround blog post. Here it is:

[1] http://onlyubuntu.blogspot.com/2008/11/howto-fix-firefox-taking-up-whole.html

Gabriel Zellmer (crosseye) said : #9

I was experiencing the same problem and finally figured out a workaround! This workaround is really simple and easy to do and is as follows...

Step 1: Press F11, once maybe twice in Firefox to get the minimize, maximize and close button back.
Step 2: If need be press the maximize button to be able to resize the window to a small size and then close Firefox.
Step 3: Open Firefox with that new small size window(notice that the minimize, maximize and close button are back) and click on the maximize button to make Firefox fit the screen. Close Firefox one more time.

This should fix the problem and doesn't require any resetting or deleting of configuration files. Hope this helps and please post back if works or not!

As ALWAYS have a GREAT day!

Gabriel

I experienced the same problem, hitting F11, maximising the window, closing (Alt F4) and re-opening firefox fixed it.

Bolwarra (tleibrandt) said : #11

The problem seems to be Firefox is set to auto-maximise on startup.
The following fix worked for me...

Check your: about:config

Locate the following Preference Name: <b>browser.fullscreen.autohide</b> It will currently be set to true.

Simply modify the value to false.

Upsurge (upsurged) said : #12

Maybe am late in replying, but the both the solutions of "Gabriel Zellmer" and "Bolwarra" fixed it. Just started experiencing the problem today. Thanks pplz.

Wichard (w-noppert) said : #13

thanks, the F11 trick worked well for me, wasn't ready to reinstall and add al my addons again.

fabiool (fabiool) said : #14

Same here, the F11 trick did the job. It would be nice to find out what caused it though ... I will be vigilant.

Wichard (w-noppert) said : #15

@fabiool, my guess is closing down ff in fullscreen one time and than messing up some setting?

Hazel (hazell) said : #16

about: config didnt work, but Gabriel Zellmer's workaround worked perfectly, thx.

fabiool (fabiool) said : #17

@Wichard, indeed FF is losing/messing up its settings when we close it maximized. Few days on and the problem is back! Annoying really!

Can you help with this problem?

Provide an answer of your own, or ask mtchaze for more information if necessary.

To post a message you must log in.