how to change firefox config param named network.online to set it true

Asked by jai

how to change firefox config param named network.online to set it true

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox-3.0 Edit question
Assignee:
No assignee Edit question
Solved by:
mziegler
Solved:
Last query:
Last reply:
Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#1

Please open Firefox and type into address bar about:config
if is the first time you are unsing about:config on firefox, a warning windows come in front of you please confirm the "promise".

Then search ( type the name into the "filter row" field ) for the firefox config param named network.online

double click on the filtered row and set it to true

quit and restart firefox

Hope this helps

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#2

Added to the faq...
FAQ #96: “firefox starts in offline mode”.

Revision history for this message
jai (jaiisgreat) said :
#3

Thanks marcobra but it doesnt work

and it is set to true by default

Revision history for this message
SSJxGojita (mpidor) said :
#4

why is this in the FAQ when it didn't solve the problem?

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#5

Usually it solve, but there is also this bug https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/191889 added to the faq.

Hope this helps

Revision history for this message
Hannes Coetzee (scorpking) said :
#6

open /etc/network/interfaces and make lo like this:

auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

save and close networkmanager. it should now work (you might have to update the routing table or just restart)

Revision history for this message
Michael Satke (n9447354) said :
#7

Dear Hannes Coetze, that did not help (Unfortunately, my Firefox starts offline, too). Wkr, Michael

Revision history for this message
Michael Satke (n9447354) said :
#8

I could sucessfully solve this problem, though through a radical method:

Using Synaptic package manager I uninstalled "firefox" and "firefox-gnome-support" completely and re-installed it. Since that Firefox always starts in online mode.

Don't forget to back up your bookmarks and passwords ;-) !! Regards, Michael

Revision history for this message
john_antony40 (john-antony40) said :
#9

Disable and stop Network Manager from services(System->Administration->Services, in Services configuration page stop and disable Network Manager).

Revision history for this message
mziegler (michael-ziegler) said :
#10

for me it worked by changing
toolkit.networkmanager.disable
to true in about:config

Revision history for this message
Best mziegler (michael-ziegler) said :
#11

actually I just found the explanation as well:
http://kb.mozillazine.org/Toolkit.networkmanager.disable

Revision history for this message
jai (jaiisgreat) said :
#12

thanks mziegler this did solve my problem but i had to make that value false and then again true to make this work.

Thank you again !!!

Revision history for this message
Springnuts (simon-springnuts-orangehome) said :
#13

Thanks - toolkit.networkmanager.disable works for me too. Springnuts.

Revision history for this message
KB (johndoesacc) said :
#14

Thanks! "toolkit.networkmanager.disable" worked for me too... Could somebody add it to the FAQ?

Revision history for this message
smhnaji (smhnaji-gmail) said :
#15

Me also ;)

Thanks mziegler :)

Revision history for this message
Marco Kar.ma (makhellion) said :
#16

I'm using Ubuntu 8.10 (Intrepid Ibex) and Firefox 3.0.6, and "toolkit.networkmanager.disable=true" solved the problem.

Revision history for this message
ontadimanamana@gmail.com (ontadimanamana) said :
#17

@mziegler

thanks you

Revision history for this message
pbhj (pbhj) said :
#18

Bug still here on Jaunty with 3.0.11. I had network manager uninstalled to fix this (!) but reinstalled to check if things had been sorted.

toolkit.networkmanager.disable works for me too, thanks.

Revision history for this message
cakecop (cakecop) said :
#19

Thanks mziegler
I am using netbook remix 10.10 with FF 3.6.13

Revision history for this message
Rick Cleland (meanderer) said :
#20

I solved the the problem for my own system.
Ubuntu 10.4 had not had this problem with Firefox until recently. With all the talk about Network Manager, I realised I had changed my network manager recently in testing a wireless router that was suffering it's own problems. Forum suggestions directed people to ditch the default Network Manager and install the Wicd Network Manager.
I uninstalled the Wicd Network Manager and reinstalled the Network Manager (original), rebooted the system, and the problem with the Offline Mode was overcome. NOTE: I went through the process again of Swapping the Network Managers and the problem was obviously occurring with the Wicd manager :(