Choppy Video Playback

Asked by Joshua on 2011-07-19

I have an Acer AspireOne (150) netbook running the netbook optimized Release 10.04 (lucid) of Ubuntu with the 2.6.32-33-generic kernel and GNOME 2.30.2. 1 GB of ram and an Intel Atom N270 Dual Core processor @1.6 GHz.

I have problems with certain video streams. Youtube plays just fine, but most other flash videos run extremely choppy. The funny thing is that commercials seem to play just fine before and after, but my actual content plays between .5 to 4 frames per second with no other programs running. Again, no issues with Youtube, but blip.tv for example is terrible. I checked the system monitor and while Youtube and commercials seem to hover around 65% processor utilization, blip.tv content sends both cores hovering right around 95% when playing. 1.6 GHz Dual Core should be plenty to stream a simple video, and my sister has the same netbook running Win Vista that plays video just fine. What can I do?

I've tried popping the video output plugin to X Windows System (no Xv) and I've installed Moonlight, but nothing has helped.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox-3.0 Edit question
Assignee:
No assignee Edit question
Solved by:
Joshua
Solved:
2011-07-19
Last query:
2011-07-19
Last reply:
2011-07-19

Can you give the output of:

lsb_release -a; uname -a; dpkg -l | grep flash; dpkg -l | grep gnash; dpkg -l | grep swf

Thanks

Joshua (joshuadouglasallen) said : #2

lsb_release -a:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ibuntu 10.04.2 LTS
Codename: lucid

uname -a:
Linux Joshua-netbook 2.6.33-330generic #70-Ubuntu SMP Thu Jul 7 21:09:46 UTC 2011 i686 GNU/Linux

dpkg -l | grep flash:
ii adobe-flash-properties-gtk 10.3.181.32-0lucid1 GTK+ control panel for Adobe Flash Player pl
ii adobe-flashplugin 10.3.181.32-0lucid1 Adobe Flash Player plugin version 10

dpkg -l | grep gnash:
(no response)

dpkg -l | grep swf:
(no response)

In future, if someone gives a command on one line, please keep it as one line. If you chop commands incorrectly, you may damage your OS. I give the EXACT command to avoid any issues like this.

If you run:

sudo apt-get --purge remove adobe-flash-properties-gtk adobe-flashplugin; sudo apt-get clean; sudo apt-get update; sudo apt-get -y install flashplugin-nonfree

Should be ok

Joshua (joshuadouglasallen) said : #4

much better. Appreciate it.

If you use the right plugin package, it works ;)