Firefox no Start

Asked by Ed Hollowell on 2010-06-12

I click to start Firefox and get the message "Firefox starting" which seems to time out in about 20 seconds without ever starting the browser. I look at system monitor and it does not show Firefox running. Other than this everything in my OS seems to be working normally. I had been keeping the system updated. Tried doing Add/Remove but it replied that firefox could not be removed and how could I reinstall if I cannot remove? I have restarted the computer to no effect. I ran spinrite on the drive with no problems shown.

It is a bit of a puzzle.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox-3.0 Edit question
Assignee:
No assignee Edit question
Solved by:
Ed Hollowell
Solved:
2011-02-05
Last query:
2011-02-05
Last reply:
2010-06-24

Open a terminal and run firefox like this

firefox -safe-mode

It may run or at least you might see some error message.
It is runs, then remove the extensions one by one until you find the one causing the problem.

Ed Hollowell (erhollowell) said : #2

This was the result-

Segmentation fault

If you don't mind losing your bookmarks, try starting firefox with a new profile:

In terminal run

rm -Rf .mozilla/

Try starting firefox then.

Try also unistalling flash plugin.

Next thing to try would be reinstalling all firefox packages from Synaptic. To reinstall, you don't have to unistall, there's a reinstall option for already installed packages.

I linked a possible related bug.

Ed Hollowell (erhollowell) said : #5

Sorry for the delay but I had to do other things.

I tried rm -Rf .mozilla/

It did not change anything.

I have read the bug report and it sounds like my problem. I don't know what the Moonlight plug in is and could not find it in the directory search. I did find java plugin helix and flash but that was all.

Any further ideas?

Ed Hollowell (erhollowell) said : #6

I removed the flash plugin and every other I could find and I can report no change. Firefox was reinstalled. It still will not run.

From related bug linked to this question workaround ( but do you have moonlight firefox plugin installed...?) do you have already tried to:

Open a terminal and type:

sudo apt-get purge moonlight-plugin-core moonlight-plugin-mozilla

2. Start firefox
3. Exit firefox

Still using terminal type:

sudo apt-get install moonlight-plugin-core moonlight-plugin-mozilla

5. Start firefox fixes the problem for me.

Ed Hollowell (erhollowell) said : #8

I never learned what the problem was, but I un-installed Firefox And re-installed it and things were fixed.

Ed Hollowell (erhollowell) said : #9

I'd like to add you to my professional network on LinkedIn.

- Edwin

Edwin Hollowell
Test Equipment Fabrication Tech at Raytheon
Greater Los Angeles Area

Confirm that you know Edwin Hollowell:
https://www.linkedin.com/e/-fdfrcb-gtghwat6-3x/isd/4483929930/CRPhJTzu/?hs=false&tok=3BYVSCFMQnb4Y1

--
You are receiving Invitation to Connect emails. Click to unsubscribe:
http://www.linkedin.com/e/-fdfrcb-gtghwat6-3x/ub55bnGKn8-mv3xWuM1TqvG1zrQ4hFl7NR0WhuhnQVN8vsx0uVhard/goo/question114393%40answers%2Elaunchpad%2Enet/20061/I1553828641_1/?hs=false&tok=0ctsqSS7Enb4Y1

(c) 2011 LinkedIn Corporation. 2029 Stierlin Ct, Mountain View, CA 94043, USA.