Firefox times out but can update other files through the net

Asked by R. West on 2010-05-29

Hi i just installed Ubuntu onto a clean drive it seemed to install properly etc however when i go to launch Mozilla it "times out" yet when all the updates needed to be installed through Ubuntu it was able to download them. I currently dont have a firewall as i have just put this on and i am new to it. I am currently using my other comp atm until i get some help. Any advice you have would be appreciated.

Internet is hard wired and the version of Unbutu is the latests one.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox-3.0 Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2010-05-30
Last query:
2010-05-30
Last reply:
2010-05-30
Ian Ace (iaculallad) said : #1

Exactly what site are you trying to open? Your DNS is working as you can perform system update.

R. West (rwest200) said : #2

any site i type in wont go to the site unless i put in their IP

Please try this open a terminal from Applications→Accessories→Terminal and type:

sudo gedit /etc/resolv.conf

give your user password when requested, you don't see nothing when you type it, then press enter.

Can you copy and paste content here...

Thank you

R. West (rwest200) said : #4

I just ran that and it is saying command not found :(

Please take care of spaces in this command please retry:

sudo gedit /etc/resolv.conf

must be typed as:

sudo <space> gedit <space> /etc/resolv.conf

Then press enter.

Than command not found is prefixed with the command so please copy the name of the command not found and post here.

Thank you

R. West (rwest200) said : #6

k will try now

R. West (rwest200) said : #7

Ty Marco i entered that and it brought up a window that is named resolve.conf(/etc)-gedit
and all inside the window is blank

I am sorry this is my first time with any form of linux i appreciate your paitence

Please take care of the file name is resolv.con not resolve.conf

To avoid type errors:

you can select the row below

sudo gedit /etc/resolv.conf

then right click with mouse and select "Copy" then open a termina and right click and select paste or please be careful on what are you typing.

Hope this helps

R. West (rwest200) said : #9

k this is what it came up with
# generated by Networkmanager
nameserver 10.1.1.1

ok seems your defined nameserver (seems your router defined nameserver) is not working or this is a wrong ip so please change it with this opendns http://www.opendns.com/ addresses:

Open the file

sudo gedit /etc/resolv.conf

delete the

nameserver 10.1.1.1

row and put in that file:

nameserver 208.67.222.222
nameserver 208.67.220.220

save and exit... and try to use Firefox.

Hope this helps

R. West (rwest200) said : #11

Thanks marcobra (Marco Braida), that solved my question.

R. West (rwest200) said : #12

Thankyou very much i am so happy!

Please note if this works you must dress your nameservers network-manager settings values using the network-manager otherwise i think you would loose this customized nameserver settings.

I think put a fixed ip with these working name servers in it might be the definitive solution.

Hth