Filezilla 3.7.3 in Ubuntu 12.04 LTS

Asked by brades on 2013-09-24

According to the LTS support on Precice, it is supported for 5 years. Why are the common apps that are core functionality not kept up to date? FileZilla is at 3.7.3 now and there isn't a valid PPA for this. It is supposedly in the default Debian uproot packages as well from what it seems. When looking at various links on the web, it shows it that way. The PPA by Nate Meunch isn't available in the Precise packages as one would expect in the LTS version!

How do we get that package in the LTS version so we can upgrade Filezilla. This client has so many issues trying to connect to ProFTPD servers! In windows clients, yes curse that word, it works just fine so it is definitely in the client and not in the ProFTPD packages them selves in Ubuntu 12.04.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu filezilla Edit question
Assignee:
No assignee Edit question
Last query:
2013-09-24
Last reply:
2013-09-24
Warren Hill (warren-hill) said : #1

Every time a package is updated it introduces the possibility that we break something. Because lots of people are reliant on Ubuntu as a serious operating system we try to avoid that.

Normally we only introduce software updates to fix problems when its a security patch or to fix a bug that has significant impact except when we release a new version of Ubuntu. A new version of Ubuntu gives us time to adequately test that a change in one package does not interfere with any other.

This is especially important with LTS releases as many people use Ubuntu for business and a broken system would be disasterous.

Manfred Hampl (m-hampl) said : #2

It seems you misunderstand the Ubuntu release philosophy. LTS does mean that the packages are supported with bug fixes for five years, but it does not mean that the packages are always updated to their most current version. If you want to have the most up-to-date version of all packages you have to use the non-LTS series of Ubuntu, with a release upgrade to be done every six months. This is due to the fact that Ubuntu is no rolling release.

I do see a PPA with filezilla 3.7.3 for Ubuntu 12.04 by Philip Muškovac, https://launchpad.net/~yofel/+archive/ppa?field.series_filter=precise

Can you help with this problem?

Provide an answer of your own, or ask brades for more information if necessary.

To post a message you must log in.