black screen upon reinstall of fglrx

Asked by Jacques Malaprade on 2013-10-03

Hi,

I have been trying to setup the vgaswitheroo after a complete reinstall of ubuntu 12.04. Along the way I uninstalled the fglrx proprietary driver and rebooted with the understanding that the standard ubuntu driver would take over. I am now at the stage where I keep on getting a black screen. I have rebooted and set the kernel boot option to "nomodeset" as indicated by some, I have also reinstalled fglrx as indicated on this page: https://help.ubuntu.com/community/BinaryDriverHowto/ATI through the command line. As well as this page: http://askubuntu.com/questions/162075/my-computer-boots-to-a-black-screen-what-options-do-i-have-to-fix-it. I keep on get this black screen. Output of the following are:

$ lspci -vvnn | grep VGA

Intel Second Generation Core Processor ......

Advanced Micro Devices, Inc [AMD/ATI] Seymour Radeon HD 6400/7400 Series

There are some lines with the words VGASnoop ParErr Stepping SERR FastB2B DisINTx

Sorry for being so cryptic but I am typing on the other PC

$ glxinfo | grep -i opengl

Error: Unable to open display

I have a HP Pavilion dv6 laptop running Ubuntu 12.04

Help is much appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu fglrx-installer Edit question
Assignee:
No assignee Edit question
Solved by:
Jacques Malaprade
Solved:
2013-10-04
Last query:
2013-10-04
Last reply:
2013-10-03

What is the output of:

sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep -i fgl

Thanks

Jacques Malaprade (malapradej) said : #2

Hi actionparsnip,

I resolved the black screen by rebooting into grub.

At reboot and grub screen press 'e' when prompted for you operating system (I have dual boot btw), and removing 'quiet splash' and replacing with nomodeset. Booting into a command line I reinstalled the ubuntu desktop:

sudo apt-get install --reinstall ubuntu-desktop

I then removed the fglrx driver and installed the Radeon driver https://help.ubuntu.com/community/RadeonDriver

And then used this page to switch off the discrete driver completely http://planetoss.com/articles/how-to-disable-the-discrete-amd-graphics-card-in-linux/#comment-824

My computer is running cooler and quite frankly I have had enough with the issues brought about by switching graphics cards and overheating due to the use of a discrete graphics card.

Hope this helps someone else out there too.