Cannot configure fglxr after installation of legacy driver on 12.04

Asked by Jan Seidensticker on 2013-07-28

I am encountering a problem when installing the proprietary driver for my ATI Radeon HD 4870. I require the closed-source
driver to be able to use Steam properly. I am using 12.04 as the newest versions of x-server and x-org do not support
the legacy driver for my GPU anymore and downgrading leads to extensive problems with Unity (I have tried that before).
I followed the procedure described under 3.1 here: https://help.ubuntu.com/community/BinaryDriverHowto/ATI
The installation works fine until the last point, I get an error message:
The second and third warnings are in German, but the problem is the same (I translated the first one).
1. update-alternatives: warning: creation of /etc/OpenCL/vendors/amdocl32.icd skipped, because the corresponding file /usr/lib/fglrx/etc/OpenCL/vendors/amdocl32.icd (of link-group x86_64-linux-gnu_gl_conf) does not exist.
update-alternatives: Warnung: Neuinstallation der Alternative /usr/lib/fglrx/ld.so.conf ist erzwungen, weil Linkgruppe x86_64-linux-gnu_gl_conf defekt ist.
2. update-alternatives: Warnung: Erstellung von /etc/OpenCL/vendors/amdocl32.icd wird ├╝bersprungen, weil die zugeh├Ârige Datei /usr/lib/fglrx/etc/OpenCL/vendors/amdocl32.icd (der Link-Gruppe x86_64-linux-gnu_gl_conf) nicht existiert.
update-alternatives: /usr/lib/fglrx/alt_ld.so.conf wird verwendet, um /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) im Auto-Modus bereitzustellen.
update-initramfs: deferring update (trigger activated)
I'm sorry that part of this is in German, as my system language is German, but I still wanted to post here so that not only German Ubuntu users read this. If there are any programs I can prompt through the terminal that may be able to supply useful information, I would be happy to do so. When I enter "sudo aticonfig --initial" I get the message "aticonfig: No supported adapters detected".

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu fglrx-installer Edit question
Assignee:
No assignee Edit question
Last query:
2013-07-28
Last reply:
2013-07-29

What kernel are you using?
$ uname -a

If it's 3.5.x, then you are using the quantal graphics stack. You need to use the precise stack (kernel 3.2 and Xserver 1.11.x) for fglrx.

sudo apt-get install xserver-xorg-lts-precise

Can you help with this problem?

Provide an answer of your own, or ask Jan Seidensticker for more information if necessary.

To post a message you must log in.