Stuck on purple/splash screen

Asked by cain on 2012-03-31

I think this is a graphics driver issue but i'm not entirely sure. I was getting stuck on the purple screen and the only thing i could do was to force reboot, only to get stuck at the same purple screen again. I followed some instructions somewhere and upgraded to the latest proprietary driver (AMD Catalystâ„¢ Proprietary Display Driver - Linux x86 & Linux x86_64) and everything went fine until i rebooted my laptop again. I can still Ctrl-Alt-F1 to login though.

Please help me diagnose/troubleshoot the problem. I am running a 64-bit Ubuntu 11.10 (GNU/Linux 3.0.0-17-generic x86_64) on a Dell Studio XPS (1645) with ATI HD4670. Do let me know if i can provide any other information. Thanks!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu fglrx-installer Edit question
Assignee:
No assignee Edit question
Last query:
2012-03-31
Last reply:
2012-04-01

While you are waiting for a valid answer: please take alook at already answered questions here:
https://answers.launchpad.net/ubuntu/+source/unity

Try the boot option:

nomodeset

HTH

cain (streetgal) said : #3

Uh huh, so i tried holding down Shift to get into the grub menu (if that's what you call it), then "e" and changed "quiet splash something something" to "nomodeset".

Before updating to the latest proprietary driver, that allowed me to log on with a graphical interface sans unity.

Now, it just shows a bunch of command lines (--verbose-like), after which i get "Ubuntu 11.10 ubuntu tty1" and can log in using the command line. Still doesn't fix the problem though.

cain (streetgal) said : #4

Tried booting into an older kernel too, doesn't make a difference... :(

Can you help with this problem?

Provide an answer of your own, or ask cain for more information if necessary.

To post a message you must log in.