Switching between open source and proprietary graphic drivers

Asked by Geoff Smith on 2011-11-06

Is there a way of switching between the Open source driver for Gnome 3 and the Proprietary driver for Unity? At present I am forced to use the default driver for both Gnome 3 and Unity as the ATI Proprietary driver causes distorted graphics in Gnome 3 - See my original question for a background on my problem -

https://answers.launchpad.net/ubuntu/+source/fglrx-installer/+question/176878

Can this be achieved without rebooting?
Thank you,
Geoff Smith

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu fglrx-installer Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-06
Last reply:
2011-11-06
Geoff Smith (taurusone) said : #2

Hi Sam,
Thanks for your quick response - please excuse my ignorance but isn't the fallback default driver the ATI driver?
I could see there were some pieces of fglrx left in my system which I will get rid of. At present I operate both Unity and Gnome 3 (my preference) without issues after I did a fresh install. I was under the impression that the fglrx driver would eventually have it's problems rectified - Is this not so? I am confused regarding whether the default driver is the ATI driver. Does the ATI driver need to be installed? Sorry to drag out the issue.
Regards
Geoff Smith

Geoff Smith (taurusone) said : #3

The only reference to fglrx that I found were in the following -
/user/share/app-install/desktop/fglrx-driver.desktop
/user/share/apport/package-hooks/source_fglrx-installer.py
/user/share/jockey/handlers/fglrx.py
Am I right in assuming that these entries are normal and don't need to be purged as per the Wiki? Or do I need to follow the purging commands?
As I previously indicated, both Gnome 3 and Unity are working without apparent issues - I now think I understand that the default driver is in fact the ATI or Radeon Driver.
I apologize for dragging out this question -

Sam_ (and-sam) said : #4

The switch can be done via 'additional drivers' in gnome-control-center aka system settings and needs a reboot.
According to Wiki interference is a known issue, if all runs well mentioned entries in #3 don't need to be purged.
And yes, ati or radeon are default.
https://help.ubuntu.com/community/BinaryDriverHowto/ATI

Can you help with this problem?

Provide an answer of your own, or ask Geoff Smith for more information if necessary.

To post a message you must log in.