How to download package fglrx 2:8.723.1-0ubuntu5 (flgrx destroyed by 10.04 12/2 auto update of kernel, can only find broken "ubuntu3")

Asked by Stephen A. Kukolich on 2010-12-05

Automatic update of 10.04 updated kernel and destroyed fglrx rebuild. 2:8.723.1-0ubuntu5 should have fix, but I can find this for download.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu fglrx-installer Edit question
Assignee:
No assignee Edit question
Solved by:
Stephen A. Kukolich
Solved:
2010-12-06
Last query:
2010-12-06
Last reply:
2010-12-05

try:

sudo apt-get --reinstall install dkms

mycae (mycae) said : #2

Maverick (2:8.780-0ubuntu2):
http://packages.ubuntu.com/maverick/fglrx

Lucid updates (2:8.723.1-0ubuntu5) :
http://packages.ubuntu.com/lucid-updates/fglrx

however, if you do this at a command line (Ctrl+alt+T, or in applications menu)

sudo aptitude update
sudo aptitude install fglrx

this should get the right version automatically from the lucid-updates

To check what version you have installed at the moment, you can use the command line (you can use the GUI too, but it takes longer for me to describe, and I can only do so very vaguely)

sudo aptitude show fglrx

I did all the above command-line steps. I am still getting fglrx 2:8.723.1-0ubuntu3 instead of
fglrx 2:8.723.1-0ubuntu5, so I am still hitting this bug :
https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/642518

I am still hoping that this can be resolved as a package manager problem.
However, if not, I am willing to do whatever it takes to install fglrx directly.

Also "apt-cache show fglrx" shows :
Package: fglrx
Versions:
2:8.723.1-0ubuntu3 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_lucid_restricted_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language:
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_lucid_restricted_binary-amd64_Packages
...

Thanks

P.S.:

More details from the aptitude install fglrx (after it was uninstalled from the synaptic package manager):
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following NEW packages will be installed:
  fglrx fglrx-amdcccle{a}
0 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 5,135kB/34.4MB of archives. After unpacking 110MB will be used.
Do you want to continue? [Y/n/?]
Writing extended state information... Done
Get:1 http://us.archive.ubuntu.com/ubuntu/ lucid/restricted fglrx-amdcccle 2:8.723.1-0ubuntu3 [5,135kB]
...
Building initial module for 2.6.32-26-generic

Error! Bad return status for module build on kernel: 2.6.32-26-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/fglrx/8.723.1/build/ for more information.
...

More details from the aptitude show fglrx :

Package: fglrx
State: partially configured
Automatically installed: no
Version: 2:8.723.1-0ubuntu3
Priority: extra
Section: restricted/misc
Maintainer: Ubuntu Core Developers <email address hidden>
Uncompressed Size: 100M
Depends: libc6 (>= 2.3.2), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1),
         libgcc1 (>= 1:4.1.1), libice6 (>= 1:1.0.0), libqtcore4 (>= 4:4.5.3),
         libqtgui4 (>= 4:4.5.3), libsm6, libstdc++6 (>= 4.1.1), libx11-6 (>= 0)\
,
         libxcursor1 (> 1.1.2), libxext6 (>= 0), libxfixes3 (>= 1:4.0.1),
         libxinerama1, libxrandr2 (>= 0), libxrender1, libxxf86vm1,
         xserver-xorg-core, lib32gcc1, libc6-i386, dkms, make, linux-libc-dev,
         linux-headers-generic | linux-headers
Recommends: fglrx-amdcccle
Conflicts: libamdxvba1
Replaces: libamdxvba1
Provides: libamdxvba1
Description: Video driver for the ATI graphics accelerators
 ...

I gave up on "aptitude" and just downloaded and directly installed
the packages using dpkg :

dpkg -i fglrx_8.723.1-0ubuntu5_amd64.deb
dpkg -i fglrx-amdcccle_8.723.1-0ubuntu5_amd64.deb

Now my fglrx driver is working again.

The synaptic GUI package now shows updated versions for these.
However it still shows wrong "Latest version" is "ubuntu3" for other (not installed
fglrx packages).

One final note : The reason why this was not just a "who cares" problem
is that it almost destroyed my laptop hardware (and it might happen
to somebody else). After rebooting after the auto update, I had not
noticed that the fglrx driver was not working (and that that meant
that the auto-suspend feature no longer worked) and I closed my laptop,
put it in my bag. If I had not opened my bag twenty minutes later
(to the loud sound of the fans) it would have overheated and destroyed
my laptop (I lost a laptop screen this way due to overheating several
years ago).