Video players and AMD video drivers

Asked by jehaz

I use Ubuntu 10.04
When I start playing video files in VLC or mplayer I see black screen like a OpenGL full-screen applications (full-screen games). After that VLC (mplayer) playing video file in window mode.
I have AMD HD5570 video card. Use driver from repository and from AMD. No different – I have a problem. When I do not install drivers from AMD (binary or from repository) – VLC (mplayer) playing video without black screen.
Sorry for my English.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu fglrx-installer Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Can you give the output of:

dpkg -l | grep vlc

Thanks

Revision history for this message
jehaz (jehaz) said :
#2

user@desktop:~$ dpkg -l|grep vlc
ii libvlc2 1.0.6-1ubuntu1.2 multimedia player and streamer library
ii libvlccore2 1.0.6-1ubuntu1.2 base library for VLC and its modules
ii vlc 1.0.6-1ubuntu1.2 multimedia player and streamer
ii vlc-data 1.0.6-1ubuntu1.2 Common data for VLC
ii vlc-nox 1.0.6-1ubuntu1.2 multimedia player and streamer (without X su
ii vlc-plugin-pulse 1.0.6-1ubuntu1.2 PulseAudio plugin for VLC
ii vlc-plugin-sdl 1.0.6-1ubuntu1.2 SDL video and audio output plugin for VLC

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#3
Revision history for this message
jehaz (jehaz) said :
#4

I tried this version of VLC. Result is zero - black screen. But the problem is present in mplayer...

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#5

Ok do you have:

ubuntu-restricted-extras

installed?

Revision history for this message
jehaz (jehaz) said :
#6

This package is not installed.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#7

Then install it and it should work fine

Revision history for this message
jehaz (jehaz) said :
#8

After installation the problem persist. I think the guilty driver ati, because if I set vlc vout=sdl the screen does not darken before playing.

Revision history for this message
jehaz (jehaz) said :
#9

I found solution!!! Thank you for your help!
xorg.conf:

Section "Monitor"
...
        Option "DPMS" "<font color=red>false</font>"
EndSection

Revision history for this message
jehaz (jehaz) said :
#10

Sorry.
I found solution!!! Thank you for your help!
xorg.conf:

Section "Monitor"
...
        Option "DPMS" "false"
EndSection

Revision history for this message
hsbs sed (jtarqz17) said :
#11

Try establishing terminal and entering "gstreamer-homes" go to the video tab and trade the output plugin to "no Xv" and test Also attempt X11 output here https://onlykinemasterapk.com/

Can you help with this problem?

Provide an answer of your own, or ask jehaz for more information if necessary.

To post a message you must log in.