Fixed fglrx-installer problem on my system

Asked by josesand on 2010-09-23

Started Synaptic - Chose Settings - Repositories - checked all options for "Downloadable from th Internet - checked all "Other Software" options - checked all "Ubuntu updates" options - refreshed repositories - chose ALL - used quick search for "ATI" - uninstalled all fglrx - installed xserver-xorg-video-ati - xserver-xorg-video-radeon - xserver-xorg-video-mach64 - xserver-xorg-video-r128 - xserver-xorg-video-radeonhd - xserver-xorg-video-radeonhd-dbg - radeontool - then marked all updates. After reboot added back - fglrx - fglrx-amdcccle - fglrx-modaliases - rebooted again - clicked System - Administration - Hardware Drivers - Installed fglrx - rebooted - I have #D effects now and can use andccc .

I don't know what actually did it but this is what I did for my hardware and it worked.

Has anyone else got theirs to work?

Not being a programmer - not being a debugger - I hope this info is useful.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu fglrx-installer Edit question
Assignee:
No assignee Edit question
Solved by:
josesand
Solved:
2010-09-23
Last query:
2010-09-23
Last reply:
josesand (josesand) said : #1

Started Synaptic - Chose Settings - Repositories - checked all options for "Downloadable from th Internet - checked all "Other Software" options - checked all "Ubuntu updates" options - refreshed repositories - chose ALL - used quick search for "ATI" - uninstalled all fglrx - installed xserver-xorg-video-ati - xserver-xorg-video-radeon - xserver-xorg-video-mach64 - xserver-xorg-video-r128 - xserver-xorg-video-radeonhd - xserver-xorg-video-radeonhd-dbg - radeontool - then marked all updates. After reboot added back - fglrx - fglrx-amdcccle - fglrx-modaliases - rebooted again - clicked System - Administration - Hardware Drivers - Installed fglrx - rebooted - I have 3D effects now and can use amdccc .

I don't know what actually did it but this is what I did for my hardware and it worked.

Has anyone else got theirs to work?

Not being a programmer - not being a debugger - I hope this info is useful.