10.04 unable to install any fglrx ATI driver

Asked by wiesshund on 2010-05-12

When upgrading from karmic to lucid i got a warning on the fglrx packages.
The install completed but minus the ATI driver.
I removed the 3 broken items in the package manager.
I looked on here and found a supposedly fixed driver asked the system to install it and this is there error that follows.

After this operation, 100MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
(Reading database ... 135793 files and directories currently installed.)
Unpacking fglrx (from .../fglrx_2%3a8.723.1-0ubuntu4_amd64.deb) ...

[Warning] Uninstall : inst_path_default or inst_path_override
 does not exist in /etc/ati. This suggests that the ATI driver
 is not installed, the ATI driver is only partially installed,
 or the current ATI driver installed is an older version than the
 one this script was designed for. Both files listed above are
 required for determining where installed files are located.
 To force uninstallation of the driver by guessing where the
 uninstallation files are located, set the FORCE_ATI_UNINSTALL
 environment variable and re-run /usr/share/ati/fglrx-uninstall.sh (this is not recommended).

dpkg: error processing /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu4_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
wiesshund@wiesshund-desktop:/usr/share/ati$

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu fglrx-installer Edit question
Assignee:
No assignee Edit question
Solved by:
delance
Solved:
2010-05-15
Last query:
2010-05-15
Last reply:
2010-05-15

sudo dpkg --force-all -i /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu4_amd64.deb; sudo apt-get -f install

Should be ok.

wiesshund (wiesshund) said : #2

I found a solution but that was not it.
I went and hand created the etc/ati directories
then i made 2 zero byte files named the same as the ones reported as missing in the error message.
inst_path_default and inst_path_override

The install then completed with out crash.

then i did the aticonfig --initial, rebooted and all was well.

Must be a slight error in the installer's script.
Would work fine as an upgrade install, but not an initial one.

Best delance (olivier-delance) said : #3

Please, could you mark question "solved" ?

Tom (tom6) said : #4

Hi :)

When i looked up fglrx in Synaptic it showed a lot of packages, such as "xorg-...-fglrx" are these all vital too?

Regards from
Tom :)

wiesshund (wiesshund) said : #5

Hmm thought i did.
Will mark it again.

Someone may want to check the error in the installer script though.

Tom (tom6) said : #6

Hi :)

I think that probably needs to be reported as a bug-report so that developers see it. If you give the solution at the same time they might cheer up

Good luck and regards from
Tom :)