Have not been able to use fglrx drivers since 14.04 am now on 15.10. It installs but boots to black screen.

Asked by Dave Stroud on 2015-09-03

Am using H.P. all in one desktop with AMD radon video.It worked fine in 14.04, am now on 15.10 gnome. It shows as installed but boots to black screen. There are several bug reports on the fglrx driver but none seem to offer any help. Does any one know a work around. The default driver works but fglrx driver is much better on my machine.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu fglrx-installer-updates Edit question
Assignee:
No assignee Edit question
Solved by:
Dave Stroud
Solved:
2015-09-19
Last query:
2015-09-19
Last reply:
2015-09-06

Well you went from the LTS where stability is champion to a release that isnt even remotely finished and not stable at all.

I suggest you report a bug

Dave Stroud (bigdavesr) said : #2

It did not work on 14.10 ,15.04 and now 15.10 . There are all ready several bugs reported on this. I am looking for a work a round. Thanks

Why not stick with 14.04, it is LTS and supported til April 2019. 14.10 is EOL, 15.04 is EOL in July next year and 15.10 is unstable...

Manfred Hampl (m-hampl) said : #4

Have you tried using the nomodeset boot parameter?

Dave Stroud (bigdavesr) said : #5

On 09/03/2015 10:21 AM, Manfred Hampl wrote:
> Your question #271052 on fglrx-installer-updates in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/fglrx-installer-updates/+question/271052
>
> Manfred Hampl requested more information:
> Have you tried using the nomodeset boot parameter?
>
> I boot win 10 gnome 1404 and 15.10. . I have filed a bug .Just would like to be able to use it on 15.04. Was hoping some one else who had the same problem.could may be help.

Yes I have . It would not work ran a purge on fglrx and that works.

--
dave stroud

Sue Street (sueestreet) said : #6

I have the same problem with 14.04 - black screen is presumably because I presumably don't have a working graphics driver any more.

Last comment from bugtracker was

Thank you for taking the time to report this bug and helping to make
Ubuntu better. Reviewing your log files attached to this bug report it
seems that a package failed to install due to a segmentation fault in
the application being used for the package installation process.
Unfortunately, this bug report isn't very useful in its current state
and a crash report would be much more useful. Could you try recreating
this issue by enabling apport to catch the crash report 'sudo service
apport start force_start=1' and then trying to install the same package
again? This process will create a new bug report so I am marking this
one as Invalid. Thanks again for helping out!

[This is an automated message. I apologize if it reached you
inappropriately; please just reply to this message indicating so.]

** Tags added: package-install-segfault

** Changed in: fglrx-installer-updates (Ubuntu)
       Status: New => Invalid

-- You received this bug notification because you are subscribed to the bug report. https://bugs.launchpad.net/bugs/1492487

Dave Stroud (bigdavesr) said : #7

I have figured this out for my self. In my case I only have problems in gnome with GDM installed. If I use LTDM or MDM, it works fine. Must be a bug in GDM.