ffmpeg configuration: xvid not enabled in ffmpeg gutsy build?

Asked by Cedric Sam

Well, it seemed like the version of ffmpeg packaged for feisty had a longer configuration line than the one for gutsy (configuration: --enable-gpl --enable-pp --enable-swscaler --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libogg --enable-libgsm --enable-dc1394 --disable-debug --enable-shared --prefix=/usr).

Specifically, I was wondering what the reason was for omitting xvid, and perhaps other options...

Thank you!


Question information

English Edit question
Ubuntu ffmpeg Edit question
No assignee Edit question
Solved by:
Cedric Sam
Last query:
Last reply:
Revision history for this message
Best Cedric Sam (cedricsam) said :

I realized that the installed package that I had was from medibuntu (http://medibuntu.sos-sts.com/), thus why it supported extra codec libraries not in the official Ubuntu version.

This how-to indirectly helped answer my question:

What I finally did was to grab a snapshot of the ffmpeg source, get the lib*-dev libraries of the corresponding codecs that I wanted with ffmpeg. My config was:

configuration: --enable-gpl --enable-pp --enable-pthreads --enable-libogg --enable-liba52 --enable-libdts --enable-dc1394 --enable-libgsm --disable-debug --enable-libmp3lame --enable-libfaad --enable-libfaac --enable-xvid --enable-x264 --enable-libvorbis --enable-libtheora --enable-libfaad --enable-libfaadbin --enable-x11grab --arch=i686

Simpler (in a sense), if one's uncomfortable with building his own binaries, was to download the last .deb from:
and then to install it directly with "dpkg -i", and then hold the package back until Gutsy is ripe enough so that someone at Medibuntu builds a binary with the added libraries that is the same version as the official Ubuntu Gutsy one.