tried to get ffmpeg program updated/upgraded and working.

Asked by Not As needi newbi on 2008-09-13

Binary package hint: gnome-terminal

here's some info on the error i got in terminal [which asked for info from the Ubuntu 8.04 Desktop i386, Hardy Heron, Long Time Support]: brian@brian-desktop:~$ apt-get source ffmpeg
Reading package lists... Done
Building dependency tree
Reading state information... Done
Need to get 2634kB of source archives.
Get:1 http://us.archive.ubuntu.com hardy-updates/main ffmpeg 3:0.cvs20070307-5ubuntu7.1 (dsc) [1325B]
Get:2 http://us.archive.ubuntu.com hardy-updates/main ffmpeg 3:0.cvs20070307-5ubuntu7.1 (tar) [2593kB]
Get:3 http://us.archive.ubuntu.com hardy-updates/main ffmpeg 3:0.cvs20070307-5ubuntu7.1 (diff) [39.4kB]
Fetched 2634kB in 3s (705kB/s)
gpg: Signature made Wed 23 Jul 2008 02:36:01 PM PDT using DSA key ID 17063E6D
gpg: Can't check signature: public key not found
dpkg-source: extracting ffmpeg in ffmpeg-0.cvs20070307
dpkg-source: unpacking ffmpeg_0.cvs20070307.orig.tar.gz
dpkg-source: applying ./ffmpeg_0.cvs20070307-5ubuntu7.1.diff.gz
brian@brian-desktop:~$ cd ffmpeg-*/
brian@brian-desktop:~/ffmpeg-0.cvs20070307$
brian@brian-desktop:~/ffmpeg-0.cvs20070307$ ./configure --enable-liba52 --disable-debug --enable-libfaad --enable-libfaac --enable-gpl --enable-amr_nb --enable-amr_wb --enable-x264 --enable-xvid --enable-libdts --enable-pthreads --enable-libvorbis --enable-pp --enable-libtheora --enable-libogg --enable-libgsm --disable-debug --enable-shared --prefix=/usr
ERROR: x264 not found
If you think configure made a mistake, make sure you are using the latest
version from SVN. If the latest version fails, report the problem to the
<email address hidden> mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.err" produced by configure as this will help
solving the problem.
brian@brian-desktop:~/ffmpeg-0.cvs20070307$
brian@brian-desktop:~/ffmpeg-0.cvs20070307$ apt-get autoremove
E: Could not open lock file /var/lib/dpkg/lock - open (13 Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
brian@brian-desktop:~/ffmpeg-0.cvs20070307$

So I went thru the steps I got from: https://wiki.ubuntu.com/ffmpeg
So this web site said: * ffmpeg

Fixing ffmpeg on Ubuntu

For a litany of legal reasons, ffmpeg does not come with all of the necessary things enabled for you to encode video for the iPod Video by default. Therefore, we need to build it from source and install some other libraries and programs, as well. Make sure you have multiverse and universe enabled.

Compiling ffmpeg from version in the repositories

In the terminal, run: Then I copied and pasted each step from this page, and it all went smooth until the end, then!

Can I get some help on this pls.? Thanks.

ProblemType: Bug
Architecture: i386
Date: Fri Sep 12 20:02:33 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/gnome-terminal
Package: gnome-terminal 2.22.1-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-terminal
Uname: Linux 2.6.24-19-generic i686

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ffmpeg Edit question
Assignee:
No assignee Edit question
Last query:
2008-09-20
Last reply:
2008-09-20
Not As needi newbi (mango553) said : #1
Parthan SR (parth-technofreak) said : #2

The source package is not gnome-terminal as the reported issue has nothing to do with gnome-terminal. Hence changing it to ffmpeg on which this bug was reported.

Parthan SR (parth-technofreak) said : #3

Thank you for taking your time to report this bug and helping to make Ubuntu better. Did you enable universe and multiverse repositories before trying the steps mentioned in the wiki? Did you run `sudo apt-get update` after you added the repositories? Can you try building it again without the --enable-x264 option to configure? If it reports any error, as mentioned in the message shown in terminal, include your configure.err and for additional help ask around in #ffmpeg. Thanks in advance.

Reinhard Tartler (siretart) said : #4

Sorry, but this obviously a user question and not a bug in the package.

Lol Grant (lol-grant) said : #5

Have you tried installing the x264 library e.g.

sudo apt-get install libx264-dev

Not As needi newbi (mango553) said : #6

Lol Grant, yes I just now ran the above, installing x264 library. Now what should I do?

Lol Grant (lol-grant) said : #7

After installing the xc64 library. you need to retry the configue:

% ./configure --enable-liba52 --disable-debug --enable-libfaad --enable-libfaac --enable-gpl --enable-amr_nb --enable-amr_wb --enable-x264 --enable-xvid --enable-libdts --enable-pthreads --enable-libvorbis --enable-pp --enable-libtheora --enable-libogg --enable-libgsm --disable-debug --enable-shared --prefix=/usr

then do a make

% make

and if that goes well, install:

% sudo make install (or run checkinstall instead)

Can you help with this problem?

Provide an answer of your own, or ask Not As needi newbi for more information if necessary.

To post a message you must log in.