Package for ffmpeg development

Asked by Jeff on 2008-07-26

Binary package hint: ffmpeg

To compile vlc manually (since the vlc repository can not be installed), we need the development package of ffmpeg - i.e., the header files etc. Install the standard ffmpeg package does not help.

My system is ps3 ubuntu 7.10, but I guess it is a general problem.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ffmpeg Edit question
Assignee:
No assignee Edit question
Last query:
2008-07-26
Last reply:
2008-07-27

This question was originally filed as bug #252206.

Reinhard Tartler (siretart) said : #1

This is obviously not a bug in the ffmpeg package in ubuntu, but a user question. Converting it to a ticket issue.

Reinhard Tartler (siretart) said : #2

ffmpeg is actually a set of single libs. You need to specify what development libs you actually need:

libavformat-dev, libavcodec-dev, libavpostproc-dev are all available and installable.

if you want to have vlc's build dependencies installed, try 'apt-get build-dep vlc' with the multiverse repository enabled.

Can you help with this problem?

Provide an answer of your own, or ask Jeff for more information if necessary.

To post a message you must log in.