totem-gstreamer crashed with SIGSEGV

Asked by terry_gardener on 2009-02-27

Binary package hint: totem

please link this to my previous bug report (Bug 334519) that i have been advised to raise a new one.

i have updated my system less than 1 hr ago using the update manager and it says that my system is up to date, so all packages are up to date as of now while posting this bug.

the .mkv files work with mplayer and vlc just not in totem.

also i have uploaded a sample file online at http://homepage.ntlworld.com/terry.gardener/test.mkv

i am still getting exactly the same issue and after reading the forums i am not the only one.

description from previous bug report
unable to play .mkv files they are crashing totem. nautilus crashes when
i try to access the properties of the file.

i have posted my problem here
http://ubuntuforums.org/showthread.php?t=1078269

it works in VLC and mplayer but not totem.

codecs of the video file (info from vlc)
video = avc1
audio = mpga

i have also looked at syslogs and it says the following

terry-desktop kernel: [ 68.576720] totem[4085]: segfault at ab36000 ip b7105377 sp b310a828 error 6 in libc-2.9.so[b708c000+15c000]
terry-desktop kernel: [ 122.168247] nautilus[4135]: segfault at aac1000 ip b7309377 sp b6be1838 error 6 in libc-2.9.so[b7290000+15c000]

 i have installed the gstreamer good, bad and ugly. bad and ugly also
have the package from the multiverse installed. also have gstreamer-
ffmpeg

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Disassembly: 0xb6fc7377:
DistroRelease: /usr/bin/lsb_release:81: DeprecationWarning: the sets module is deprecated import sets Ubuntu 9.04
ExecutablePath: /usr/bin/totem-gstreamer
NonfreeKernelModules: nvidia
Package: totem-gstreamer 2.25.91-0ubuntu2
ProcCmdline: totem /media/disk/home/username/Videos/cascada-what_hurts_the_most-x264-2007-se_int.mkv
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: totem
Stacktrace:
 #0 0xb6fc7377 in ?? ()
 #1 0x80808080 in ?? ()
StacktraceTop:
 ?? ()
 ?? ()
ThreadStacktrace:

Title: totem-gstreamer crashed with SIGSEGV
Uname: Linux 2.6.28-8-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ffmpeg-debian Edit question
Assignee:
No assignee Edit question
Solved by:
Remco Hijink
Solved:
2009-03-09
Last query:
2009-03-09
Last reply:
2009-03-09

This question was originally filed as bug #335595.

I can confirm this bug with almost the same setup

StacktraceTop:?? ()
?? ()

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libxrandr2: installed version 2:1.2.99.4-1, latest version: 2:1.2.99.4-2
libpam-runtime: installed version 1.0.1-5ubuntu1, latest version: 1.0.1-5ubuntu2
libcups2: installed version 1.3.9-14ubuntu1, latest version: 1.3.9-14ubuntu2
libpam0g: installed version 1.0.1-5ubuntu1, latest version: 1.0.1-5ubuntu2
libpam-modules: installed version 1.0.1-5ubuntu1, latest version: 1.0.1-5ubuntu2
liblaunchpad-integration1: installed version 0.1.22, latest version: 0.1.23
libtheora0: installed version 1.0~beta3-1, latest version: 1.0-2

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

sorry to reopen this bug but if i raise another bug report then with the pace that ubuntu jaunty is getting updated than i is going to be out of date when the you look at it.

i have made sure the packages mentions above are update to date and then retried and get the same problem.

i have done a backtrace and also valgrind as it is segmentation fault. see attachments

changing it back to new as i dont agreed with the status invalid as this is the second bug report submitted after the problem has occured on a updated system twice.

Sebastien Bacher (seb128) said : #8

the issue is an invalid read in libavcodec but it lacks debug informations

Sebastien Bacher (seb128) said : #9

could you add a video example to the bug?

Pedro Villavicencio (pedro) said : #10

not a totem issue, rejecting the task.

Sebastien Bacher (seb128) said : #12

the video doesn't crash on my jaunty installation

please can you advise how to fix my problem then.

for example what packages do i need installed for it not to crash, etc etc

Sebastien Bacher (seb128) said : #14

no idea how to fix your issue I just don't get the bug there and so can't work on it

The problem is not in Totem itself, i completely reinstalled totem and still had the same problem, opening the same video with gst-launch gave me this result:

gst-launch-0.10 playbin uri=file:///home/remco/Desktop/test.mkv
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Caught SIGSEGV accessing address 0x9f18000
*** glibc detected *** gst-launch-0.10: malloc(): memory corruption: 0x09d56580 ***
Segmentation fault (core dumped)

Completely removing libavcodec, all it's dependencies and packages which seemed like the same of libavcodec did the trick. It works again!

Thanks Remco Hijink, that solved my question.