1.fcitx configuration does not work. 2. Only first 5 charachters available for selection

Asked by Lukasz Sarek on 2013-01-05

1. fcitx configuration tool does not work. I can change skins, can change input method (one of 4 input methods included in standard installation form repository) but clicking on the "configure" option does not trigger configuration tool.
2. Only first 5 characters afre availabel for selection. Clicking on the arrow shaped button that should switch characters list and show next 5 characters (or words) does not work. No reaction.

in language settings fcitx is selected as input method
in input method switcher fcits also selected as input method

System: Ubuntu 12.04
fcitx was installed from Ubuntu repository (not compiled, standard installation)
fcitx version: 4.2.0
reinstallation does not help.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu fcitx Edit question
Assignee:
No assignee Edit question
Last query:
2013-01-06
Last reply:
2013-02-25
yuyichao (yyc-1992) said : #1

Can u first upgrade to the latest version? 4.2.6.1 from fcitx nightly ppa @ https://launchpad.net/~fcitx-team/+archive/nightly (it is really not nightly but stable so don't worry about that)

Please also install fcitx-configtool (if u haven't) or kcm-fcitx from the ppa. U should be able to set words per page in the configtool.

Also please install and use im-config instead of the default im-switch to select input method.

Lukasz Sarek (lsarek) said : #2

Tried to implement Your advise as follows:
A. upgrade via ubuntu software center:
1. added source ppa:fcitx-team/nightly to the source list in ubuntu soft center and provided authentication using command line (publi key was shown in soft center autentication sections so it worked)
2. upgraded soft to verssion 4.2.6.1
3.removed im-switch 1.20ubuntu5.1
4. intalled im-config 0.7
5. run fcitx form dash
6. run im-config in terminal and switched inout method to fcitx,
result: application did not work at all, CTR+Space does not trigger fcitx,

so in im-config I had fcitx set as input method, but soft did not worked (similar cases reported by other users)
Next steps
7. uinstalled version 4.2.6.1 via software center
8. removed source ppa:fcitx-team/nightly and revoked authentication for thsi source by removing public key,
9. rebooted system
10. again installed the fcitx version 4.2.0 via software center (in sofotware center goes in package with skins and configuration tool), it is shown in software center as installed and the version shown is 4.2.0
11. run fcitx from dash
12. again run im-config and set fcitx as input mehod,
and result worse then before CTRL+Space do not trigger fcitx, in spite of fact that fcitx was triggered by clicking icon in Dash, it is not triggered, in processes list fcitx is not shown (but the icon is shown in the launcher and can be clicked even reacts but does not trigger application to start working)

how can I get it working and working correctly?
seems like application does not work at all is not even triggered in spite of fact that installed and.

yuyichao (yyc-1992) said : #3

U need to log out and log in again (or reboot) after choosing fcitx in im-config (or im-switch). Plz remember to install any recommended packages as well, especially fcitx-frontend-{gtk2,gtk3,qt} and at least one input method (they are split in ppa, not sure about the official repo), (you can also install fcitx-cloudpinyin and it will work just out-of-box when u are using any pinyin input method).

Plz make sure the packages I mentioned above are installed (fcitx, fcitx-frontend*, fcitx-configtool/kcm-fcitx + input method(s)) and please check ur GTK_IM_MODULE and QT_IM_MODULE environment variables are successfully set to "fcitx" by im-config (ur problem with 4.2.6.1 is very likely caused by these environment variables not correctly set probably because u haven't relogin after using im-config).

Plz always use the latest version of fcitx from ppa. We cannot provide any support for out-of-date versions especially for a version as old as 4.2.0. If u still have any problem, few free to ask either here or on our googlegourp (sth like <email address hidden> ... cannot remember exactly................) but plz only use the latest fcitx from ppa.

Lukasz Sarek (lsarek) said : #4

thanks for reply, unfortunately app still not working correctly,
my bad - not informed in previous e-mail that after inpout method switched and fcitx launched without effect I rebooted system and again tried to launch fcitx so, not logging out after inout metod change was not the reason for problems,
trying again:
1. added public key for this ppa: sudo add-apt-repository ppa:fcitx-team/nightly
2. checked in the software center is ppa added as source anf if key authenticated, everything ok, already in software sources
3. Updating / upgrading software including this ppa form terminal with command line, trying this way to upgrade already installed previoius fcitx version 4.2.0 to the new one 4.2.6.1,
- not working, still versions 4.2.0 shown as installed,
so
4.as not sure how repo will work with packages having Manually downloaded packages from this location:https://launchpad.net/~fcitx-team/+archive/nightly/+packages
packages downloaded:
fcitx_4.2.6.1-1~precise_all.deb
fcitx-bin_4.2.6.1-1~precise_i386.deb
fcitx-data_4.2.6.1-1~precise_all.deb
fcitx-frontend-all_4.2.6.1-1~precise_all.deb
fcitx-frontend-gtk3_4.2.6.1-1~precise_i386.deb
fcitx-frontend-qt4_4.2.6.1-1~precise_i386.deb
fcitx-frontend-gtk2_4.2.6.1-1~precise_i386.deb
fcitx-modules_4.2.6.1-1~precise_i386.deb
fcitx-module-dbus_4.2.6.1-1~precise_i386.deb
fcitx-pinyin_4.2.6.1-1~precise_i386.deb
fcitx-tools_4.2.6.1-1~precise_i386.deb
fcitx-table-all_4.2.6.1-1~precise_all.deb
fcitx-table-ziranma_4.2.6.1-1~precise_i386.deb
fcitx-table-erbi_4.2.6.1-1~precise_i386.deb
fcitx-ui-classic_4.2.6.1-1~precise_i386.deb
fcitx-module-cloudpinyin_0.3.0-1~precise_i386.deb
fcitx-config-common_0.4.5-1~precise_all.deb

5. then one by one installed or upgraded every file via software center (command: open with ubuntu software center) depending on what was the command in software center,
all packages above were installed or upgraded,
all shown as installed corrrectly no conflicts, no reported issues with dependencies,

6. after pckages installed running im-config in terminal, set fcitx as input method
rebooted system,

7. after systemn reboot searching for fcitx in dash, not found only configartion tool, no reaction after launching configuration tool,

8. fcitx after installation was included in launcher, trying to launch it, also not reaction,
altought application is launched (clicked the icon in launcher) it is not shown in the list of processes (neither as in active not sleep status), seems like application does not start working
however according to list of packages all essential packages are installed,

9. just checking Libre office, trying to trigger application with CTRL+Space, no result,

10. checking in software center the versions of packages installed, all newest versions as download list above installed, so not the issue that soe old packages left without upgrade,

How address this issue, fcitx is currently the only application under ubuntu that causes problems for me, all other apps are working correctly, so either list of packages I installed is not complete or incorrect or must be a bug or other malfunction in the system that blocks fcitx from launch.

yuyichao (yyc-1992) said : #5

..... plz remove unnecessary information from ur question (e.g. adding key, I'm not a ubuntu user so there's nothing I can help if u have a broken installation ................................ although I may be able to notice it from the following checks.. :P ..)
plz run everything from cmd line, start from dash won't give u any helpful information (or error.) (as a matter of fact, providing information of launching from dash is almost never a good idea when asking for help unless ur problem is with dash itself... =).)
since u haven't install fcitx-configtool, the config icon u see in the dash is actually a wrapper script which will try to launch a editor to edit the configure file (and will fail if the environment variable EDITOR is not set) and I suppose this is what u r experiencing with configtool. (I agree that the name is confusing, i.e. fcitx-configtool executable is a wrapper script included in fcitx itself and the fcitx-configtool package provide fcitx-config-gtk3 which provide a gui configure interface and is supposed to be spawned by fcitx-configtool executable).

so here r sth u may want to test:
1. install fcitx-configtool package, which should provide a fcitx-config-gtk3 executable (or sth similar.... not sure if ubuntu have renanmed it), after that (no need to reboot) running fcitx-configtool in command line should give u a gui configure interface.
2. there are some environment check (including the QT_IM_MODULE and GTK_IM_MODULE check which u probably forgot to mention :P ) that u can do. The easiest way is to download and run this script [1] (which will be included in the next release). u can paste the output in github (gist) since it may be too long to fit here and the output is in markdown format which can be correctly highlighted by gist.
3. plz try to launch fcitx in the command line, by default it will start in background so the command line u may want to use is `fcitx -Dr`
4. plz check the right click menu of gtk and qt apps as shown in this page [2] (u don't need to set environment variables like this, just check if fcitx is in the menu as shown in the screenshots.) (libreoffice is not a good choice for checking these stuff, u may want to test with simpler editors like gedit or kwrite.)

plz provide error message(or other cmdline output) and/or other issue u have noticed in the above 5 checks. They should provide enough information to narrow down ur problem (or I may need to improve my diagnose script, which is a good thing to do looool.)

[1] https://github.com/fcitx/fcitx/blob/master/data/script/fcitx-diagnose.sh
[2] http://fcitx-im.org/wiki/Configure_(Other)

Lukasz Sarek (lsarek) said : #6

Dear Yuyichao,
Thank You for trying to help but the issue is that I'm neither the dev nor linux geek so working with terminal and command line is not my strong point.
As for launching form dash -it's not completely unnececessary information, if soft works well should be run form dash, if not integrated with dahs I consider it as malfunction,
fcitx configtool is installed as a part of pacjage form repo so no need to install is separately, it just does not work, problem described above,
as for QT and GTKL envirioment, diagnose script that needs time to learn,

I also have fresh installation of Ubuntu 12.10 just one day, almost no additional software installed and fcitx was installed just after system installation, on the othe rmachine, installed fcitx from ubuntu repository )via software center)
does not work at all, possibly some dependencies conflict,
On both machines (one with 12.10 and another one 12.04) ibus input method works perfectly well, no problems with any other applications installed, the only application not working correctly on my machines or not working at all is at the moment fcitx,
maybe the problem is not the broken installation of 12.04 as You suggested but dependencies conflict, libraries whatever.
As I'm only a user not developer or tech geel do not have time and knowledge to check what exactly is wrong and why fcitx does not work while other input methods work (and yest after every change of input method is restart or log out -log in)
 it just does not work correctly with two ubuntu installations on two different machines,

Greetings

yuyichao (yyc-1992) said : #7

1. You don't need to be a dev or geek, simply copy the command line in a terminal, run it, and provide the result.

2. Ok, saying running fron dash is a little useful since it tells me why there isn't much useful information.

3. fcitx-configtool[1] (ok, real package name fcitx-config-gtk) is NOT part of the main fcitx package, the icon in the dash means doesn't means you have fcitx-config-gtk installed (it means you have the wrapper script installed as I mentioned).

4. In case you don't know how to download and run a bash script, VERBATIM paste the following line to a terminal, hit <Enter> and than paste the result.

    bash <(curl https://raw.github.com/yuyichao/fcitx/master/data/script/fcitx-diagnose.sh)

5. There should never be a dependency conflict. Fcitx doesn't require any special version of other libraries. And if some error really happens during your installation, there should be a error message from software center which you should have noticed and mentioned.

6. This is why we are trying to make fcitx the default in the future, so that you don't need to install and change the settings yourself (just as ibus does now). And please do not try to guess what is wrong unless you know what is happening. Just provide the information we are asking for and we will provide a better guess.

7. In all, if I have understand correctly, your problems are
1). not being able to configure fcitx
2). cannot go to next page by mouse click
3). cannot activate fcitx in some applications

For 1), please install fcitx-config-gtk as I mentioned.
For 2), it is only supported in 4.2.8 that is not released yet. use keyboard shortcut -/= to do that (shortcut can be changed in configure gui).
For 3), making sure im-switch is cleanly removed and fcitx is selected as input method in im-config. If there is still any problem after this, please provide the output of diagnose script using the command line above.

[1] https://launchpad.net/~fcitx-team/+archive/nightly/+sourcepub/2689708/+listing-archive-extra

Can you help with this problem?

Provide an answer of your own, or ask Lukasz Sarek for more information if necessary.

To post a message you must log in.