trying to install Nvidia Drivers

Asked by George3634

Binary package hint: fakeroot-ng

They are the new/home/george/Desktop/

ProblemType: Package
Architecture: i386
 libgcc1 1:4.3.3-5ubuntu4
 gcc-4.3-base 4.3.3-5ubuntu4
 findutils 4.4.0-2ubuntu4
 libc6 2.9-4ubuntu6
DistroRelease: Ubuntu 9.04
ErrorMessage: subprocess pre-removal script returned error exit status 2
Package: fakeroot 1.12.1ubuntu1
SourcePackage: fakeroot
Title: package fakeroot 1.12.1ubuntu1 failed to install/upgrade: subprocess pre-removal script returned error exit status 2
Uname: Linux 2.6.28-11-generic i686

Question information

English Edit question
Ubuntu fakeroot-ng Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

This question was originally filed as bug #389239.

Revision history for this message
George3634 (george2343) said :
Revision history for this message
Chris Coulson (chrisccoulson) said :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at if you are uncertain if they are bugs. For help on reporting bugs, see

Revision history for this message
actionparsnip (andrew-woodhead666) said :

You are doing this the VERY hard way.

There are 2 easy ways to do this:

sudo apt-get install jockey-gtk; gksudo jockey-gtk

or if that doesnt work:

sudo apt-get install nvidia-glx-185

will do EXACTLY the same thing and will also perform DKMS when you upgrade your kernel. If you use the method you are trying you will not get an x server when you first boot a new kernel as the nvidia module will not exist. You will then have to rerun the file you have.

I suggest sticking to repository based stuffs instead of the nvidia .run files.

Let us know how you fly

Revision history for this message
George3634 (george2343) said :

NVIDIA Drivers,

Hardware Drivers
NVIDIA accelerated graphics driver (Version 180) [Recommended]
This Driver is activated and currently in use

I use two monitors and I cannot get the {Version 180} Driver to work.
NVIDIA Server knows that my other monitor is there but does not let
it work. I cannot get it to show as a Mirror Screen.

The second monitor will not work at all. When I install Ubuntu 9.04,
I do have have Mirror Screens. After I install Version 180 NVIDIA Drivers
my second monitor stops working and stays {Black}!!!

I don,t want to Mirror them, I want separate Monitors, like I had in Windows XP.
This is beganning to get to me. Can you help me to solve this problem?
Thank each and everyone for any help given.


Revision history for this message
actionparsnip (andrew-woodhead666) said :

The nvidia-settings app will easily let you do this. nvidia cards have by far the best support in Linux. You need to install the driver first. After that you can set this up easily

Revision history for this message
George3634 (george2343) said :

Thanks for your answer actionparsnip, I have just started using Ubuntu and I sure as hell don,t know what it is that I am doing. I can,t even get the updated Drivers from NVIDIA to install. l go to System, Administration, Hardware Drivers and it supposedly installed them for me.

So how do I install them, I downloaded the updated Drivers from NVIDIA and I can't get them to install. I would like to keep on using Ubuntu but if I can,t do a simple thing like installing a driver, it's not going to be of much use to me.

I am 58 yrs. old and don't need the hassle of a system that every time I want to do something, it takes a week or more for me to figure it out or find help. Hey, sorry about that, it's just my frustration coming out.

I taught myself how to use Windows and I am wondering if I want to go through this again!!! I am like everyone else, tire of paying out good money for stuff that doesn't.
                                                                                                               Again, Thanks for the help.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

just run:

sudo apt-get install nvidia-glx-180

if you use this, all dkms with upgrades will be managed for you. It is very rare in ubuntu to not use the repo system.

Once you have ran the command it will set up the kernel module for you and be fine after a reboot.

You are getting into a new OS, It is not windows so will have different issues. It is by no means perfect but no OS is perfect. You will need to learn the new OS as you have learned windows. Its good to learn something new though.

Revision history for this message
George3634 (george2343) said :

I ran, sudo apt-get install nvidia-glx-180 here is the answer I got. Reading state information... Done
nvidia-glx-180 is already the newest version. The following packages were automatically installed
and are no longer require:
Use' apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded
george@george - desktop

I still don't have separate monitors and still have the same problem after two weeks. Do you have
anymore suggestions? The more I search and read the more confused I get.

                                                                                                       George 3634

Revision history for this message
Best actionparsnip (andrew-woodhead666) said :

ok then if you hit

alt+k+prntscrn the x server will restart. If you then run:

gksudo nvidia-settings

and you can setup your display as you wish. Remember to write the settings to xorg.conf afterwards so that the settings are permanent.

a single command will rarely get you what you want in Linux let alone any OS.

If you want to get rid of the unnecessary package you have you can run:

sudo apt-get --purge autoremove

and it will go.

You have much to learn of this OS so reading is a good thing.

Revision history for this message
George3634 (george2343) said :

That worked and you are right I have a lot to learn, thank you very much for your help, it is
much appreciated.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

no worries fellah. Have a fun journey. Just take it slow and read as much as you can. In Linux, little victories feel great :D