f spot export function fails no matter what.

Asked by Gary Mercado


 i inserted an sd card on to my laptop, and f-spot quickly detected and upload the contents to laptop ( my late mother photos)
earlier today i decided to move all photos to dvd so i can view it to a larger tv screen using a dvd player.
the problem now is , i can't export it to dvd/cd and f-spot is giving me an erroe message " no file or directory available"

Glib.Gextension:No such file or directory
at Glib.FileAdapter.Copy (File Destination,FileCopyFlags flags, GlibCancellable cancellable, GlibFileProgressCallBack progress_callback) [0x00000] at FSpotCDExport.CDExport.Transfer ( ) [0x00000]

                             ERROR TRANSFERRING

i check all files and folders and i can't find the photos, no folder-no files, no photos no what so ever, but when i open/start f-spot.it shows all content of my sd card. i even notice the photos that suppose to remain on sd card disappear too. sd card now empty, i inserted my sd card back to windows laptop and all contents are gone. Prior to this, me and my sisters was able to add more pictures and view it from windows laptop, so i am sure that sd card is working well and so as digital camera in use.

then i check the image information, i noticed theres no details except that it is categorized as .JPG file and date included
no size, exposure, focal length, (file read error), no histogram..
i also notice some of the functions are not working like zoom, rotate, thumbnail etc..

next thing i did, import some files from my hard drive.
photo>import>selct file> etc etc etc.....
pictures from inernet downloads and other photos sent to me by friends that i kept on picture folder, uploaded to f-spot easily then next thing happened i have a dialog box and that i have the option to burn it to dvd , i did not continue the process of burning but the point that it gave me the option, at least there is a chance i can transfer photos to disc,
my main problem is about the photos from sd card, how can i find and extract it back where ever they are now and transfer to dvd disc if no way ubuntu can find it ..

again, f-spot shows the missing photos every time i will open f-spot, but no where in home, file system, hard drive..
no copy/paste option on f-spot to at least make it easier to create a copy.. i do not know..
please help, missing photos are so dear to family and the original copy is gone too during upload to this ubuntu laptop.
i can not duplicate those, i must find way to get it ,
if i move to ubuntu 10.04, all will be deleted , as of now i am hanging to this just because of that photos which i forgot almost 6 months now.
i will provide more info if needed..
oh, i forgot, during the process of exporting the photos, there are instances the f-spot just closes and restart is needed.
it also affected the upper panel, deleted all icons and notification icons..
this might help to diagnose the problem..


Question information

English Edit question
Ubuntu f-spot Edit question
No assignee Edit question
Solved by:
Gary Mercado
Last query:
Last reply:
Revision history for this message
Gary Mercado (gary18) said :

i found solution to this already.
here's how i saved the photos
i browsed the files,
i saw thumbnails folder and opened it.
i saw all photos and in .png type
i click a photo and open it by gimp,
click "add layers" then click the " save as" at the same time changing the name
the photos now save to pictures folder,
once in picture folder, i opened the photo again with gimp
change the .png file ot jpeg .
when all photos in jpeg format.
i opened f-spot and started importing the files.
after importing, i exported the photos to CD,
transfer is done in instant
i can now view the photos using my dvd player connected to a wide tv screen..

problem now solved