Can I switch off evolution imap server ping?

Asked by Stephan Elsner on 2007-05-16

Evolution wants to ping imap server of my provider but sadly that is not allowed and I get annoying error messages from evolution.
How can I switch off the ping?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu evolution Edit question
Assignee:
No assignee Edit question
Last query:
2007-05-22
Last reply:
2007-12-18
Stephan Elsner (elsni) said : #1

Evolution wants to ping imap server of my provider but sadly that is not allowed and I get annoying error messages from evolution.
How can I switch off the ping?

Massimo Forti (slackwarelife) said : #2

Thanks for your question, you have probably active the time post control. Try di disable it to stop the request to the server. Thanks

Stephan Elsner (elsni) said : #3

Time post control? Do you mean that evolution scans the mail server for new messages periodically? No, it's switched off.

Massimo Forti (slackwarelife) said : #4

Thanks. Ok I mean "evolution scans the mail server for new messages periodically". But you have it off. You can report the exactky error you recive ??? Thanks

Stephan Elsner (elsni) said : #5

Thank you for your answers.
Yes, the ping message occurs even if I switch off "time post control". I have three ubuntu machines and it is switched off everywhere - and every mashine shows the "cant ping server" error.

Massimo Forti (slackwarelife) said : #6

Sorry, which version of ubuntu are you using now. Thanks

Stephan Elsner (elsni) said : #7

I'm using Feisty with latest updates

Massimo Forti (slackwarelife) said : #8

Open a shell and do:

$: evolution

After work and post the result of the shell output. Thanks

Stephan Elsner (elsni) said : #9

Here comes the output. The original I was writing the question did not produce any output. the lines "process 8402" and following were written after quitting evolution (kliking the close button on the evolution main window)

elsni@kraftklotz:~$ evolution
CalDAV Eplugin starting up ...

(evolution-2.10:8402): evolution-mail-WARNING **: ignored this junk plugin: not enabled or we have already loaded one

(evolution-2.10:8402): e-utils-WARNING **: Plugin 'Spamassassin-Plugin' failed to load hook 'org.gnome.evolution.mail.junk:1.0'
** (evolution-2.10:8402): DEBUG: mailto URL command: evolution %s
** (evolution-2.10:8402): DEBUG: mailto URL program: evolution
process 8402: The last reference on a connection was dropped without closing the connection. This is a bug in an application. See dbus_connection_unref() documentation for details.
Most likely, the application was supposed to call dbus_connection_close(), since this is a private connection.

Massimo Forti (slackwarelife) said : #10

I remeber you. I try to search on the net. You have done some other test ??? Thanks many

there really should be an option to stop this - in fact, why does it even bother - just try the imap connection? I think this is a bug that should be passed upstream. In my case it looks like evolution is waiting for the ping to work (which will never happen) - so it slows down acceptance of email.

Manuel (manuel-vacelet) said : #12

I confirm I have the same issue using evolution with an imap server that block icmp requests (ping). I'm using an up to date Gutsy.

Allen Riddell (ariddell) said : #13

I'd like to turn off the obtrusive error as well. Using gutsy.

Chris Roddy (cmr) said : #14

Has this been passed upstream yet? This behavior is totally pointless, as it suspends all message filtering activity in order to display a useless warning about transient network troubles.

Simon (simschi) said : #15

Years passed by and I still have the same issues here with latest updates...

Francis Yaw Amoah (fya) said : #16

Same issue here with precise.

Alessandro Lattao (blackhole) said : #17

Same here :D

Same problem with Ubuntu 12.04 and Evolution 3.2.3 on imap.laposte.net
The message is "disconnected from the server by unexpected way..."

Can you help with this problem?

Provide an answer of your own, or ask Stephan Elsner for more information if necessary.

To post a message you must log in.