evolution imap with comcast

Asked by Phil Norisez on 2015-06-22

Comcast/Xfinity is pushing us to go to IMAP instead of POP, so trying to do this. Keep getting a message from evolution about imap.comcast.net disconnecting on a ping. Want to know if this indicates a real problem or is just an artifact of incompatibility between ubuntu evolution and comcast/xfinity.

Error reads as follows: "Error while Pinging IMAP server imap.comcast.net. Server unexpectedly disconnected. Connection timed out."

Evolution info: 3.2.3

Ubuntu info: 12.04 (precise) kernel info: 3.13.0-55-generic

Question information

English Edit question
Ubuntu evolution Edit question
No assignee Edit question
Solved by:
Phil Norisez
Last query:
Last reply:

ping imap.comcast.net

Pinging imap.g.comcast.net [] with 32 bytes of data:
Reply from bytes=32 time=96ms TTL=53
Reply from bytes=32 time=95ms TTL=53
Reply from bytes=32 time=95ms TTL=53
Reply from bytes=32 time=95ms TTL=53

Can you ping that IP?

Phil Norisez (norisezp) said : #2

I can ping both imap.comcast.net and imap.g.comcast.net with the ping utility. However, that is not the topic of this question/bug. It is that evolution reports an error. Is this a problem or a bogey?

Phil Norisez (norisezp) said : #3

Further, I can ping directly with the ping utility. However, when I ping either imap.comcast.net or imap.g.comcast.net, the replies come from imap.po.sys.comcast.net (

Have you contacted Comcast to verify the settings to use?

Phil Norisez (norisezp) said : #5

Yes, see the following:

To configure an email client to use Comcast email (@comcast.net), the following settings should be used
for sending and receiving email:
Only If Needed
Incoming Mail
Server - imap.comcast.net imap.comcast.net
Incoming Mail
Server - Port 993 with SSL ON 143 with SSL ON
Outgoing Mail
Server -
smtp.comcast.net smtp.comcast.net
Outgoing Mail
Server - Port
587 (SMTP) 465 (SMTPS)
checked checked
Authentication Comcast ID and Password required

Sorry if this seems cryptic but this window would not preserve the tabular nature of the content. See
for more details.

Manfred Hampl (m-hampl) said : #6

There was a similar problem by someone else https://answers.launchpad.net/ubuntu/+source/evolution/+question/233857
Changing the DNS server to the Google one seems to have helped in that case.

I am a bit astonished to read that actionparsnip gets a reply from when he pings imap.comcast.net, but you get a reply from

Phil Norisez (norisezp) said : #7

Mr Hampl,

Thank you, but I want to know more before I fiddle with system files.
First of all, why does adding "nameserver" to /etc/resolv.conf change the DNS server to Google. Is some special IP belonging to Google?
Second, the way I interpret it, /etc/resolvconf/resolv.conf.d/head contains the system default for DNS, while /etc/resolv.conf contains the current default, correct?
Third, where can I go to find out more about DNS handling under ubuntu and/or linux in general?
Since the post you cite is old, I have put these questions in this post, which has been more lately monitored.

I have again tried the various pings, confirming my previous report of IPs in all respects. Might this have something to do with the fact that I use comcast/xfinity as my ISP, as well as, mail server? is the IP of Google's primary public DNS service. is their secondary.

The head file contains the text saying "don't modify this file" and is added to the top of /etc/resolv.conf when it is generated. You can edit the file but if DHCP is ran, the changes will be lost. By putting lines in the head file it will add the nameserver line, even if DHCP is used.

Phil Norisez (norisezp) said : #10

I am still getting the message from evolution, but it doesn't seem to be affecting email fetching, so I guess that it IS a bogey.

Phil Norisez (norisezp) said : #11

A search for "evolution ping" reveals that this problem is not unique to comcast nor to this questioner:

Answered 6709 Can I switch off evolution imap server ping? 2007-05-16 Stephan Elsner — Answered
Answered 1858 Need to ping server before send or receiving using POP3 2006-09-22 rjhutt — Answered
Solved 268423 evolution imap with comcast 2015-06-22 Phil Norisez — Solved
Answered 118 Timout error in evolution 2005-11-11 Philip Graetz — Answered
Solved 83263 Evolution with 1and1.com 2009-09-19 richnvel — Solved
Solved 3965 Send/Receive grayed out in evolution 2.9.92 2007-03-01 |Fred Krogh — Solved
Solved 233857 connection timing out 2013-08-11 David Danforth — Solved
Solved 68498 Error while Fetching Mail. (Evolution, Jaunty) 2009-04-24 Larry Vogler — Solved
Solved 120667 Noob ?: Evolution "Login Failure" when attempting Send/Receive 2010-08-11 Popeye.Tom — Solved

I have added this information to the referenced bug report.

Phil Norisez (norisezp) said : #12

This seems to have gone away in more recent versions of ubuntu/evolution/comcast, so setting this post to solved.