how to send incoming messages directly to a folder?

Asked by solrize

Related: #14424 #11821 #6076

I'm using Evolution 2.8.1

I'm on certain mailing lists and have filter rules to move list messages to folders that I've made for those lists. Incoming messages arrive through imap and land in my general inbox folder. I can hit ctrl-A to select all the messages and ctrl-Y to apply the filters to move the messages, but it's a slow operation that I don't want to have to do manually. Instead, I'm trying to figure out how to run the filter rules on each message the instant it arrives, so mailing list messages go immediately into their proper folders without ever touching my general inbox folder and without my having to do anything manually.

I think the related questions mentioned above all are trying to do the same thing, but none of the answers really seem to accomplish the goal, maybe because the questions were asked in an unclear way. Again, the goal is to run the filter rules on incoming messages automatically with no manual intervention. Any advice would be much appreciated. Thanks.

Question information

English Edit question
Ubuntu evolution Edit question
No assignee Edit question
Solved by:
Tim Starling
Last query:
Last reply:
Revision history for this message
Bhavani Shankar (bhavi) said :


1) Set up your email accounts

2) On evolution main page create a new folder for each mail account e.g.

    <email address hidden>

    <email address hidden>

3) Create sub folders in each mail account of inbox,sent,etc


4a) Set up incoming filter rules first >ADD. For each account add recipient contains <email address hidden> then move to <email address hidden>/inbox

4b) Do the same for outgoing messages EDIT > MESSAGE FILTERS >OUTGOING >ADD
For each account add sender contains <email address hidden> then move to folder <email address hidden>/sent

5) Once all the filters have been set up you need to go EDIT > PREFERENCES

6) select an account and EDIT>DEFAULT Click on SENT and the relevant folder

7) Do the same for DRAFTS

do the same for each account..

Good Luck!

Bhavani Shankar.

Revision history for this message
Best Tim Starling (tstarling) said :

Your question was perfectly clear, and it's a pity that Bhavani Shankar didn't bother to read it before pasting in a standard filter setup answer. I was having the same problem.

The solution to the *actual* problem is to enable "Apply filters to new messages in INBOX on this server", which is in your account preferences under the "Receiving Options" tab.

An even better solution would be to patch Evolution to use a more intelligent set of defaults.

Revision history for this message
solrize (solrize) said :

Thanks Tim Starling, that solved my question.

Revision history for this message
Chris Pimlott (launchpad-chris) said :

Tim's tip is correct. One thing I noticed, though, is that it didn't actually start automatically filtering until I closed and reopened Evolution (probably because that forces the account connection to close and reopen).