Unable to install evolution on ubuntu, mint etc..

Asked by Martin Masar on 2013-11-27

Hi,

Im unable to install evolution via your ppa :(

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  bogofilter bogofilter-bdb bogofilter-common evolution-common evolution-data-server evolution-data-server-common evolution-plugins gnome-icon-theme-full
  highlight highlight-common libebackend-1.2-7 libebook-1.2-14 libebook-contacts-1.2-0 libecal-1.2-16 libedata-book-1.2-20 libedata-cal-1.2-23
  libedataserver-1.2-18 liberror-perl libevolution libgsl0ldbl libgtkhtml-4.0-0 libgtkhtml-4.0-common libgtkhtml-editor-4.0-0 libgweather-3-6 liblua5.1-0
  libmail-spf-perl libnetaddr-ip-perl libpst4 libsys-hostname-long-perl libytnef0 re2c spamassassin spamc
Suggested packages:
  db5.1-util evolution-exchange evolution-dbg evolution-data-server-dbg gsl-ref-psdoc gsl-doc-pdf gsl-doc-info gsl-ref-html razor libnet-ident-perl libdbi-perl
  pyzor libmail-dkim-perl
The following packages will be REMOVED:
  evolution-data-server-goa
The following NEW packages will be installed:
  bogofilter bogofilter-bdb bogofilter-common evolution evolution-common evolution-plugins gnome-icon-theme-full highlight highlight-common libebackend-1.2-7
  libecal-1.2-16 libedata-book-1.2-20 libedata-cal-1.2-23 libedataserver-1.2-18 liberror-perl libevolution libgsl0ldbl libgtkhtml-4.0-0 libgtkhtml-4.0-common
  libgtkhtml-editor-4.0-0 libgweather-3-6 liblua5.1-0 libmail-spf-perl libnetaddr-ip-perl libpst4 libsys-hostname-long-perl libytnef0 re2c spamassassin spamc
The following packages will be upgraded:
  evolution-data-server evolution-data-server-common libebook-1.2-14 libebook-contacts-1.2-0
4 upgraded, 30 newly installed, 1 to remove and 9 not upgraded.
Need to get 0 B/26.8 MB of archives.
After this operation, 90.4 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 194528 files and directories currently installed.)
Preparing to replace evolution-data-server 3.8.5-1ubuntu3 (using .../evolution-data-server_3.11.2~git20131107~1fe576b-fta1~13.04_i386.deb) ...
Unpacking replacement evolution-data-server ...
dpkg: error processing /var/cache/apt/archives/evolution-data-server_3.11.2~git20131107~1fe576b-fta1~13.04_i386.deb (--unpack):
 trying to overwrite '/usr/lib/evolution-data-server/registry-modules/module-trust-prompt.so', which is also in package evolution-data-server-goa 3.8.5-1ubuntu3
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support ...
Errors were encountered while processing:
 /var/cache/apt/archives/evolution-data-server_3.11.2~git20131107~1fe576b-fta1~13.04_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any suggestions?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu evolution Edit question
Assignee:
No assignee Edit question
Last query:
2013-11-27
Last reply:
2013-11-27

Why are you using a PPA when evolution is in the official repositories and is known to work.

Did you even read your own output?

Did you report a bug to the PPA maintainer?

Martin Masar (sp4rh4wk) said : #2

well cause I need newest version that I can use fully office 365 with evolution.
On official repositories is version, where its not works.

I wasnt sure, that this is actually a bug..

Martin Masar (sp4rh4wk) said : #3

and sry to tell you, but I dont know exactly how to report it... :(

What is the output of :

lsb_release -a; uname -a; apt-cache policy evolution

Thanks

Martin Masar (sp4rh4wk) said : #5

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.10
Release: 13.10
Codename: saucy
Linux ubuntu 3.11.0-13-generic #20-Ubuntu SMP Wed Oct 23 17:26:33 UTC 2013 i686 i686 i686 GNU/Linux
evolution:
  Installed: (none)
  Candidate: 3.11.2~git20131108~c695c32-fta1~13.04
  Version table:
     3.11.2~git20131108~c695c32-fta1~13.04 0
        500 http://ppa.launchpad.net/fta/gnome3/ubuntu/ saucy/main i386 Packages
     3.8.4-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ saucy/main i386 Packages

You can resolve this with:

sudo dpkg --force-all -i /var/cache/apt/archives/evolution-data-server_3.11.2~git20131107~1fe576b-fta1~13.04_i386.deb

sudo apt-get -f install

The package overlap needs resolving so I suggest you email the maintainer of the PPA and let them know. This sort of thing is why normal users should not use PPAs as they simply don't have the ability to fix issues, as this page demonstrates.

Send this text too. It highlights the problem

dpkg: error processing /var/cache/apt/archives/evolution-data-server_3.11.2~git20131107~1fe576b-fta1~13.04_i386.deb (--unpack):
 trying to overwrite '/usr/lib/evolution-data-server/registry-modules/module-trust-prompt.so', which is also in package evolution-data-server-goa 3.8.5-1ubuntu3

Can you help with this problem?

Provide an answer of your own, or ask Martin Masar for more information if necessary.

To post a message you must log in.