connection timing out

Asked by David Danforth on 2013-08-11

I frequently receive the following message:

"Error while Pinging IMAP server imap.zoho.com.
Server unexpectedly disconnected: Connection timed out"

Additionally, I receive a similar message when Evolution is 'storing' to the inbox associated with 'imap.zoho.com'.

Both messages can be dismissed with a 'dismiss' button. Evolution seems to be working properly otherwise. That is, I continue to receive the messages available on 'imap.zoho.com'.

In another post, a user with a similar, but unsolved problem was asked to query some information. I have done the same, herewith:

david@david-ratu1-1204:~$ df -h; lsb_release -a; uname -a; apt-cache policy evolution
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 241G 22G 207G 10% /
udev 1.9G 4.0K 1.9G 1% /dev
tmpfs 751M 920K 750M 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 1.9G 156K 1.9G 1% /run/shm
192.168.0.19:/volume1/household-management 913G 538G 376G 59% /opt/diskstation-2/common-3
192.168.0.19:/volume1/music 913G 538G 376G 59% /opt/diskstation-2/music-3
192.168.0.19:/volume1/photo 913G 538G 376G 59% /opt/diskstation-2/photo-3
192.168.0.19:/volume1/video 913G 538G 376G 59% /opt/diskstation-2/video-3
192.168.0.19:/volume1/distro-backups/ubuntu-1204-ratu1-2013-07 913G 538G 376G 59% /opt/diskstation-2/david-ratu1-1204bu
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise
Linux david-ratu1-1204 3.5.0-37-generic #58~precise1-Ubuntu SMP Wed Jul 10 17:48:11 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
evolution:
  Installed: 3.2.3-0ubuntu6
  Candidate: 3.2.3-0ubuntu6
  Version table:
 *** 3.2.3-0ubuntu6 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Lastly, Evolution is set to check for messages on 'imap.zoho.com' every 22 minutes. That said, new messages seem to appear at intervals shorter than that.

I would like to know how to eliminate the error messsages. Thank you for your help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu evolution Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2013-08-11
Last query:
2013-08-11
Last reply:
2013-08-11
Thomas Kr├╝ger (thkrueger) said : #1

Last thing first: Nowadays most IMAP servers support the IDLE command and can keep up the connection, so new mail is delivered to the client instantly outside the check interval.

But your general problem seems to be related to a connection or server problem. Check your internet connection and ask the support of your mail provider if there have been technical problems lately.

If you change nameserver is it better?
Is the provider presently having issues?

Thanks

I also use Evolution as a client for mail.messagingengine.com (FastMail IMAP.) The error messages do not appear with FastMail. I have posted a message to the Zoho Mail forum regarding imap.zoho.com. I will post their reply when I receive it, but I have not heard from them as of this writing.

Try:

echo "nameserver 8.8.8.8" | sudo tee /etc/resolv.conf > /dev/null

Then retry

david@david-ratu1-1204:~$ sudo -i
root@david-ratu1-1204:~# echo "nameserver 8.8.8.8" | sudo tee /etc/resolv.conf > /dev/nul
root@david-ratu1-1204:~#

That seems to have worked. I understand that this is a temporary reset to the Google Public DNS service. (I'm a noob and don't have a background in this area.)

The fact that it has worked should, then, indicated that there is a DNS problem going to imap.zoho.com, but, evidently, not to anything else.

Who would know how to fix this permanently? Zoho? My ISP?

Thanks for your help. This appears to be real progress.

You didnt need to run 'sudo -i' the file edit will happen with the command as I gave it.

If there is a DNS issue with your current DNS, you can make the change stick with:

echo "nameserver 8.8.8.8" | sudo tee -a /etc/resolvconf/resolv.conf.d/head > /dev/null

again, you DON'T need to run 'sudo -i' the tee command is ran with sudo, so has root access and therefore write access to the file.

You can reboot to test

Thanks, Andrew. Got it.

Thanks actionparsnip, that solved my question.