IMAP SMTP Send Server

Asked by zzzxxx on 2008-01-25

Hello, Im using evolution and i have a school email (student.ednet.ns.ca) that i like checking in there, i have set it up to use IMAP as receiving/moving and SMTP for sending, but the SMTP keeps trying to send through my personal server (eastlink.ca). and thus doesnt pass authentication and wont send :(
there doesnt seem to be an option to change this, atleast none i saw. help

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu evolution Edit question
Assignee:
No assignee Edit question
Solved by:
EmmaJane
Solved:
2008-01-26
Last query:
2008-01-26
Last reply:
2008-01-26

Is there an SMTP server at school you could use?

Alternatively you could open a tunnel back to a machine at home if you have broadband there?

sudo ssh -L:25:<eastlink_smtp_server_hostname>:25 <home_machine>

Then tell evolution to send mail to "localhost" and it will tunnel out over the ssh connection to your home machine.

there is an SMTP server at the school, but when i use my school account on my computer through evolution it tries sending the mail through another server I use for SMTP, which wont pass its authentication, the reason I don't just modify it to use that other server is because that server is for my anonymous mail, and I don't want the school to know i have an account on that server...

if i use the alternative option, what do i put in place of <home_machine>?
its giving me: ssh: //xsanf: Name or service not known
when i put : sudo ssh -L:25:smtp.student.ednet.ns.ca:25 //xsanf

Best EmmaJane (emmajane) said : #3

The "sudo ssh" line is typed into a terminal window each time you log into the machine. It is basically a command that says, "when I try to use port 25, I actually want you to go through my home machine instead of that other eastlink machine."

The terminal can be found at: Applications -> Accessories -> Terminal.

There's more information about it here:
http://www.oreillynet.com/pub/a/wireless/2001/02/23/wep.html

Note that the # prompt means they are using the root user. In the sample command given by Alan, you use "sudo" to mean, "when I issue this command I am doing it as the root user." You will be prompted for your password (not the root password).

Thanks emmajane, that solved my question.