filter on sender doesn't work

Asked by jake on 2012-10-08

I've created an email rule for several spam items in my mailbox. I specified deletion as default action for unwanted emails. It just doesn't work. I still get same emails in my inbox. Do the mail rules actually work in Evolution or they are there to make the menu look more handsome? It's quite annoying taking into account that most spam is resistent to unsubscibing.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu evolution Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-08
Last reply:
2012-10-10
Gary (gary+ubuntu) said : #1

You said "unwanted emails" implying more than one. I have seen this problem and have two suggestions. First, when you have more than one sender (condition) you need to set the "Find Items" from the default of "If all conditions are met" to "If any conditions are met".

The "If all" means all conditions must be true so the email would have to come from all senders at once. This fixed it for me, and I almost always forget to set it the first time!

The second option would be a single rule per sender, that would help verify that rules are being applied. I would test by first moving the email to another folder to confirm it worked. Then change to delete for the action and confirm it continues to work.

Lastly, when you display the Message Filters dialog, make sure you are applying rules for Incoming emails versus outgoing email.

Can you help with this problem?

Provide an answer of your own, or ask jake for more information if necessary.

To post a message you must log in.