[quantal] Anyone able to add gmail account to evolution?

Asked by Michael Flaig on 2012-09-11

I'm running quantal

gnome-online-accounts is configured for gmail, but no account visible in evolution
manual setup in evolution goes like
Fill out Name and Email address, -> Next
All settings pre-filled, summary is shown with option to add calendar and contacts -> Finish
No account created, no logs on console. No error in GUI.

Anyone have more luck?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu evolution Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Flaig
Solved:
2012-09-12
Last query:
2012-09-12
Last reply:
2012-09-11
Michael Flaig (mflaig) said : #2

Did you even read the entire Question?
This question is specific to quantal (beta1) where evolution does fill in all settings on it's own if you only give it the gmail address. However after the setup is done no account appears.

If you set it up manually, does it work?

Michael Flaig (mflaig) said : #4

Manual setup is not easily possible. Even giving a wrong email address doesn't help to trick the wizard.. As soon as you enter some googlemail account data at any point in the evolution wizard it does automatically detect a google account and treats it as such.

The only way around is to create a totally wrong account with random servernames.
Then finish the wizard. The random account is set up.
Then go back to settings. Edit the account to gmail servers and rename it and so on.
Now it works.
contacts and calendar need separate setup of course if you do it this way.

I suspect this has something to do with ubuntu online-accounts and/or gnome-online-accounts not working side-by-side or gnome-online-accounts not working right at all.

Do you run a quantal setup and can you try it yourself to confirm?
I already killed all evolution settings files in my home to be sure it is not just some legacy config or something that confuses evolution.

As we are in beta1 now I think it's time for a bug report.

In general I believe the gmail account should be there automatically after setting up the gmail account through gnome-online-accounts.

I agree, sounds like a bug

Marek Tyburec (marek-tyburec) said : #6

Same problem here, after beta 1 fresh install. Did you report a bug?

Michael Flaig (mflaig) said : #7

Bug report #1049513 created and linked to this question.
Setting the question to solved.