Evolution will not connect to iCloud imap server

Asked by Jason Urso on 2012-04-25

Didn't want to report this as a bug until I first asked the question, but I can't connect to the iCloud imap and smtp servers with Evolution. I've been able to test my settings are correct by connecting with Thunderbird. The auto configure on Thunderbird correctly determines all the settings:

Incoming: IMAP, imap.mail.me.com. SSL
Outgoing: SMTP, smtp.mail.me.com, STARTTLS
Username: username (no trailing @me.com)

Settings according to Apple: http://support.apple.com/kb/HT4864

I've tried numerous combinations of username with and without the trailing @me.com. Nothing seems to work.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu evolution Edit question
Assignee:
No assignee Edit question
Solved by:
Jason Urso
Solved:
2012-04-26
Last query:
2012-04-26
Last reply:
2012-04-26

Can you ping the servers?

Jason Urso (jasonurso) said : #2

Actually no..

imap.mail.me.com and smtp.mail.me.com don't respond to ping.

could be a thing. Can you ping other websites?

Jason Urso (jasonurso) said : #4

Yes. Ping works fine for other sites/servers.

Again, Thunderbird determines all the settings as well and pulls in the emails/contacts/etc...

Those particular servers however do not respond to ping all other ones I can think of do.

Additional Info:
After a considerably long time Evolution responds with this:
'The reported error was "You must be working online to complete this operation".'

This happens while other email accounts (gmail) are getting new emails, so Evolution is NOT offline.

Jason Urso (jasonurso) said : #6

Yes I've seen that post. Thanks. No help unfortunately. It contains the same settings that Thunderbird and the apple support page are putting out. Evolution and/or the smtp and imap servers at apple aren't playing well together. The question is, is this a bug, or is Apple blocking evoloution for some reason. I run my own server and imap via evolution works fine, along with several other email accounts I run through Evolution.

I'm not technicall enough to figure out where the breakdown is. Just want to know at this point if its a bug or not.

Jason Urso (jasonurso) said : #7

Well.. I deleted the account, quit out and entered the server info like before and this time it worked. Here are the relevant settings.

Identity:
<email address hidden>

Receiving Email:
IMAP
Server: imap.mail.me.com
Port: 993
User Name: username (do not include the @me.com)
Security: SSL
Authentication: Password
Check the box for Remember password

Sending Email:
SMTP
Server: smtp.mail.me.com
Port: 587
check the box for requires authentication
Security: TLS
Authentication
Type: Login
User Name: username (do not include the @me.com)
Check the box for Remember password

Everything else as you like.

Thank you, Jason.

This thread helped me out greatly in setting up my account. I had a problem upon initial setup where I could only receive and not send.

After replicating your steps and settings you provided, everything works now. It may have been the deletion of the initial account that fixed the issue since I also tried various settings just through editing. This could very well be a bug of some sorts.

Kudos.