Ubuntu

Why has Evolution stopped accessing Yahoo POP mail?

Asked by flatlander on 2012-03-12

I've been using Evolution for email with various email providers, including Yahoo for years with no problem.

Since the past week or so, I've noticed Evolution displaying "error while fetching mail" at the bottom of the window during send/receive. No other hints that anything is wrong. I discovered it was a problem with Yahoo by disabling my email a/c in preferences, which stopped the message. Sure enough, checking my Yahoo inbox thru the web showed it was full of unread mail. I tried deleting and reconfiguring the settings for my Yahoo a/c in Evolution, but no change.

I thought this must be a Yahoo problem because Evolution has been working fine for years.
I've just tried accessing Yahoo POP mail under WinXP / with Outlook and it works fine, so it looks like an Evolution problem. Interesting that this only affects Yahoo though???

Was an update released for Evolution recently? Something's got messed up somewhere...

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu evolution Edit question
Assignee:
No assignee Edit question
Solved by:
flatlander
Solved:
2012-03-14
Last query:
2012-03-14
Last reply:
2012-03-12

yahoo emails are still comming though for mr do you have the right settings my are

 Incoming Mail Server (POP3) - plus.pop.mail.yahoo.com (SSL enabled, port 995)

 Outgoing Mail Server (SMTP) - plus.smtp.mail.yahoo.com (SSL enabled, port 465, use authentication)

flatlander (juggle) said : #2

yeah, I have the right settings. thanks.

this has been working fine for years.

now I have a problem, but only with yahoo.

weird.

flatlander (juggle) said : #3

I see that this happens with Evolution on both my netbook and PC, so it is probably something to do with an update.

R-j-schulz (r-j-schulz) said : #4

I am having the same problem with Evolution (not) accessing yahoo mail. It worked for almost 10 years without a problem, but since around March 10, 2012 I have been getting the following error when I try to access my email:

Error while Fetching Mail.
Failed to read a valid greeting from POP server pop.mail.yahoo.com

I am running Ubuntu 10.04 LTS and have Evolution 2.28.3.

I can telnet to both ports 110 and 995 of pop.mail.yahoo.com, so I do not think this is a firewall problem.

Was there an update to Evolution or did Yahoo change something on their server?

flatlander (juggle) said : #5

yeah, I forgot to say that I'm also running 10.04 LTS and Evolution 2.28.3

flatlander (juggle) said : #6

> Failed to read a valid greeting from POP server pop.mail.yahoo.com

at least it's telling you what the error is!

flatlander (juggle) said : #7

A pop-up just appeared, asking for my POP password for my Yahoo a/c, which I entered.
All seems to be working again now..
:)

R-j-schulz (r-j-schulz) said : #8

As of this evening, Evolution is also accessing my yahoo email. It looks like this is fixed.