HELO command failed: Invalid HELO/EHLO

Asked by Graeme on 2010-04-30

When trying to send mail from Evolution in Ubuntu 10.04 LTS I get the error message ...
 "HELO command failed: Invalid HELO/EHLO of [192.168.1.2]

I can receive mail just fine but sending leaves the mail in the outbox and the message box pops up. Unfortunately this is my first experience with Linux mail so I am pretty non clued up.

Graeme

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu evolution Edit question
Assignee:
No assignee Edit question
Solved by:
Graeme
Solved:
2010-05-02
Last query:
2010-05-02
Last reply:
2010-04-30

What is your remote mail server that you are trying to send email through?

Graeme (gvj) said : #2

Hi Michael,

Thanks for the response. I am sorry but I don't really understand the question but here is my setup.

My local machine 192.168.1.2 is wireless connected to an adsl modem/router and on a telephone line to my isp. (mail.orcon.net.nz). It does not matter if I enable security or not.

Another thing I notice is that in my Mail panel on the LHS of evolution the outbox shows 1 message but when I look in the box it says "There are no messages in this folder".

Thank you for your interest,
Graeme

Graeme (gvj) said : #3

Further to my last comment. When I exited evolution and started it up again the message showed in the outbox.

Stephen Day (sd) said : #4

It looks like the mail server is misbehaving to me. Using an IP address for a HELO name should be valid.

Can you talk to whoever manages this mail server?

Graeme (gvj) said : #5

Hi Stephen,

Thanks for your response. You have set me on the right path and I realize that I changed isp's at the same time as moving to Linux. My old isp who I am keeping a mail account with requires me to use port 25 (or port 587 if you are not on an Orcon Internet connection) -- a quote from their web faq. All I need to do is now figure out how to change my default port for that account (I am running two) and I should be there. After your "heads up" I enabled my second email account with a different isp and it worked fine.

Again thanks for your time. ... Graeme