How to install evolution-mapi 0.32.2 (or better) in Lucid (10.04 LTS) to fix problem with recurring events

Asked by Justin on 2011-07-27

I am attempting to configure Evolution 2.28.3 to communicate with Microsoft Exchange Server 2007 using the evolution-mapi 0.28.3 package. Email works great, however, the calendar has problems parsing recurring events (they do not show at all in Evolution). Singleton events show just fine.

This bug (#513394, https://bugs.launchpad.net/ubuntu/+source/evolution-mapi/+bug/513394) seems to be fixed in a patch implemented in version 0.32.2, however I am at a loss on how to include this update. 0.28.3 is the only available version in Synaptic and installing from source starting generating errors (some of which I fixed by installing the correct dependences) and others that could not be fixed with what is available in Synaptic.

Any help would be appreciated.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu evolution-mapi Edit question
Assignee:
No assignee Edit question
Last query:
2011-08-01
Last reply:
2011-08-02

What is the output of:

lsb_release -a; apt-cache policy evolution

Justin (gte975p) said : #2

$ lsb_release -a; apt-cache policy evolution

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.3 LTS
Release: 10.04
Codename: lucid
evolution:
  Installed: 2.28.3-0ubuntu10.3
  Candidate: 2.28.3-0ubuntu10.3
  Version table:
 *** 2.28.3-0ubuntu10.3 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
        100 /var/lib/dpkg/status
     2.28.3-0ubuntu9 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages

Justin (gte975p) said : #4

The repository suggested in your link only provides an updated version of Evolution (2.28.3.1 to 2.30.3), but does not provide a new evolution-mapi package.

Manfred Hampl (m-hampl) said : #5

A version of evolution-mapi 0.32.1-0ubuntu2 for lucid is available in ppa:kklimonda/backports

That seems to be the best you can get.

Justin (gte975p) said : #6

Manfred,

So close! Unfortunately, there were build failures for that package (see https://launchpad.net/~kklimonda/+archive/backports/+packages).

Manfred Hampl (m-hampl) said : #7

Sorry for missing the info that there was a build failure.

I have checked the buildlog and see missing dependencies. Checking them shows that there are ppas that have the packages in the required version available (in kklimonda/evo232); the libmapi-dev package is available on ppa:openchange/daily (not the most recent build which failed also, but version 0.11+bzr1961~ppa90~lucid1).

So apparently to fulfill the dependencies there is everything available what is needed, but scattered among different sources. I do not know how to best combine all these sources, and of course I do not know if evolution-mapi would then build with the combination of all these packages.

Can you help with this problem?

Provide an answer of your own, or ask Justin for more information if necessary.

To post a message you must log in.