How to clear Evince's history list of files viewed and stop it launching at boot-up?

Asked by Gordon Oulsnam on 2009-11-16

Hello!

In Ubuntu 9.04 Evince persists in showing me at boot time two frequently viewed pdf files. I don't want Evince to start at boot time and I don't want it to keep any 'recently visited' list of files either.

1. How do I clear Evince's history list?

2. How do I stop Evince (and any other unwanted user application) from automatically starting at boot time?

I usually, though not always, shut down with all desk-tops completely cleared, and I can vouch for the fact that 'Control Centre --> Startup Applications --> Options' shows that the 'Automatically remember running applications when logging out' option box is not ticked - and in fact never has been, so that would not seem to be the reason for Evince's constant and unwanted appearance at every reboot.

Interestingly, if I forget to close the Terminal Emulator window on some desk-top, it too will reappear on the next boot, but does so only if left running from the previous session, and never otherwise.

I also have the problem of constant unwanted reappearance with the 'Sound Preferences' window at boot time.

The problem of the unwanted appearances only began when I lost all sound in Ubuntu for some unknown reason and restored it via the 'Volume Control: HDA Intel (Alsa mixer)' window. Coincidence perhaps, or might there be a connection?

If there is some configuration file that is responsible for noting user applications that are to be started at boot-up I would have no qualms in editing it.

I hope you can help!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu evince Edit question
Assignee:
No assignee Edit question
Solved by:
Gordon Oulsnam
Solved:
2009-11-17
Last query:
2009-11-17
Last reply:
2009-11-16
Sam_ (and-sam) said : #1

Evince files are cleared out here automatically, (never used save gnome-session also).
Try as workaround to clear recently used files via panel menu places.

Also you may take a look into your home folder, gnome2 or local and search for a gnome-session file, removed it.
https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/34321

Gordon Oulsnam (aeschylusjp) said : #2

Hi Sam,

Many thanks for your reply.

I found gnome-session in ~/.config, deleted it as you suggested and that stopped Evince from auto-starting - but not the 'Sound Preferences' window from reappearing.

Next, I went to ~/.config/autostart and moved out the file
gnome-settings-sound, and that stopped the 'Sound Preferences' window from auto-starting.

As for clearing Evince's history list, I deleted ~/.recently-used.xbel
but that didn't work - which wasn't a surprise as there was no reference to either Evince or its remembered files in it. I'm afraid I don't quite understand your advice regarding 'panel menu places', but I'll persevere with it.

Anyway, the main nuisance of unwanted start-up applications has now been removed thanks to your help - very much appreciated!

Sam_ (and-sam) said : #3

Gordon,
glad you've found gnome-session file.
This is what I meant
http://www.ubuntu.com/files/GutsyImages/Places-Menu.jpg
and 'Recent Documents' = ~/.recently-used.xbel

I've opened a .pdf file in evince and it appeared in 'Recent Documents', hence it will be removed if this option is cleared.

Gordon Oulsnam (aeschylusjp) said : #4

Hello again, Sam

Ah, now I understand! Once again many thanks for your time and trouble in answering my questions. Yes, indeed, Places --> Recent Documents followed by accepting the Clear option worked perfectly! Sorry not to have picked up on that earlier, and again many thanks!