[Print] menu item unavailable

Asked by Olray on 2007-05-31

Trying to print a dvi file (LaTeX output) on my old HP laserjet printer, the menu item "File>Print" is already grayed out. This only happens for dvi files.

The menu items "File>Page settings" and "File>Preferences" is also unavailable so there is no obvious way to change e.g. the printer resolution,

Any help appreciated, thanks :)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu evince Edit question
Assignee:
No assignee Edit question
Solved by:
Olray
Solved:
2008-08-12
Last query:
2008-08-12
Last reply:
2007-06-07

This question was reopened

Cesare Tirabassi (norsetto) said : #1

Known bug and workaround in this report:

https://bugs.launchpad.net/ubuntu/+source/evince/+bug/66379

Olray (olray) said : #2

The ppd file for my LaserJet 6L already exists and touching it didn't work - as expected since touch only creates non-existent files and updates the timestamp.

I should note that problems only arise when displaying DVI files. PDF prints nicely and so does almost everything else. (PDF, JPG and GIF tested)

I'm using a default install of i386 Ubuntu 7.04 with Gnome so there shouldn't be a problem with any incompatibilities. The only recompiled piece of software is TrueCrypt.

Cesare Tirabassi (norsetto) said : #3

I don't think that cups includes a filter for DVI files (you can check in /etc/cups/mime.types and /etc/cups/mime.convs).
Unless you want to make your own filter you can use dvips (included with the texlive-base-bin or tetex-bin packages), to convert from DVI to PostScript and then print the PostScript file.

Olray (olray) said : #4

Problem solved, thank you. I have to get used to the fact that, unlike Windows, not everything visible on-screen can be printed. :)

Olray (olray) said : #5

Sorry for reopening this question. I did as you asked, to write a cups filter for DVI files with help from IBM:

http://www.ibm.com/developerworks/library/l-dvi-filter.html?ca=drs-

I think I have done everything as listed in this post, yet evince doesn't enable the Print menu item for dvi files. Is there a way to tell evince that cups is now able to print dvi files? Does this filter script work for you? If it's possible to print dvi files it should be added to the menu. Somehow.

Cesare Tirabassi (norsetto) said : #6

I'm wondering if this is an endian problem. According to my info the magic number for dvi is 0x02F7.

I tested this on a dvi file I have found on my HD:

od -N2 -tx temp.dvi -> 0000000 000002f7

Olray (olray) said : #7

Problem solved in Gutsy.