Evince Won't Save Copy

Asked by KitchM on 2017-02-19

Has anyone in the USA had this problem?

Open US federal tax return form in pdf format, fill it out, select to save a copy, copy already exists, over-write file, yes, file does not save. Red bar flashes across top of Evince screen stating something about file permissions, and all filled fields are blanked out and all data is lost.

However, file permissions are read and write for the user.

This problem is same whether one tries to save current year form or previous year form, so it does not appear to be the pdf files.

I did not have this problem last year. Did Evince change from last year. (My video card did but nothing else.)

Xubuntu 14.04.5 with Evince (document viewer) 3.10.3.

I see there is a much later version, but that is not available in Ubuntu Software Center. (Why?)

Question information

English Edit question
Ubuntu evince Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Ubuntu is not a rolling release so packages are not updated just because a new version is available. If there is a reason to upgrade a package (security / big fixes) then it will be updated sooner rather than later.

Do other PDF applications work OK and allow you to save back to the file system?

Revision history for this message
KitchM (tech-frontrowcomputer) said :

Yours is a good question. The problem I've had in the past is that some viewers will not recognize the form fields and allow the user to fill them in. That is why I has settle on Evince. It was the only program that allowed native handling of the documents.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Have you tried Adobe's reader (if it's still made for Ubuntu)?

Revision history for this message
KitchM (tech-frontrowcomputer) said :

Is it?

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Is acroread in the partner repository? If so, install it.

Revision history for this message
KitchM (tech-frontrowcomputer) said :

What is "partner repository"?

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Couldn't use the web to find out?......


Revision history for this message
KitchM (tech-frontrowcomputer) said :

If you stop and think you will understand that the web does not know your thoughts when you used the words as you did. No amount of searching ever explains the thought patterns of an other's meaning. That is why we must ask the questions.

However, the link you provided was helpful and seemed to explain your meaning.

Which raises the questions:
If this is such a necessary feature, then why is it disabled by default? Wouldn't users need the native software capabilities? Besides, isn't that part of the purpose of being "partners"? Bizarre terminology and/or logic, if you ask me.

But even more to the point, Ubuntu Software Center returned the following when searching for acroread with partner repos enabled:
No items match acroread. Software center was unable to come up with any suggestions that may aid in your search.

Synaptic Package Manager did no better but gave the following when attempting to update package lists:
Failed to fetch http://ppa.launchpad.net/upubuntu-com/office/ubuntu/dists/trusty/main/binary-amd64/Packages 404 Not Found
Failed to fetch http://ppa.launchpad.net/upubuntu-com/office/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found
Some index files failed to download. They have been ignored, or old ones used instead.

Obviously, there remains a problem with obtaining the necessary program, or there has been a change in Ubuntu's application of Evince between now and this time last year. Neither is the user's causation.

Revision history for this message
KitchM (tech-frontrowcomputer) said :

This issue has become moot as it is unlikely that Evince will be fixed, and because good substitutes have been found. For those with the same problem, I recommend in this order:
Master PDF Editor 3 found at https://code-industry.net/free-pdf-editor/
Okular found in Ubuntu Software Center