unhandled MIME type application/octet-stream

Asked by GeorgeBass on 2008-07-16

I have Ubuntu 8.04 installed. When viewing the Fidelity Investments web site, clicking on a report causes evince to open and display an error: unhandled MIME type application/octet-stream. Hovering the mouse over the link for the report results in display of javascript:void(0); at the bottom of the screen. There is no option presented to open with another application.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu evince Edit question
Assignee:
No assignee Edit question
Solved by:
Harvey Muller
Solved:
2008-07-21
Last query:
2008-07-21
Last reply:
2008-07-19
Bhavani Shankar (bhavi) said : #1

Hello

Its a well known bug in ubuntu

https://bugs.edge.launchpad.net/ubuntu/+source/evince/+bug/163764

and please feel free to add your comments there

PS: I have already reported your issue and you can wait for further assistance

Regards

Harvey Muller (hlmuller) said : #2

George,

I am checking to see if the information provided previously resolved your question. If so, please mark this question Solved.

Thanks!

Harvey

GeorgeBass (georgemarge1) said : #3

Harvey,

  I'm sorry, but Bhavani Shankar's answer didn't help. I've looked for some type of "codec" or "filter", but have been unsuccessful. This was not broken in earlier versions of Ubuntu! I say this because I visit the web site in question fairly regularly, and have been able to see the reports. I'm now booting into Windows XP, where I have no problem with the format.

Thanks, George

Best Harvey Muller (hlmuller) said : #4

George,

Can you point me to a page, and identify a link on Fidelity's website which causes you the same problem? I am looking for a link on a public page, since I do not have an account with them.

Thanks!

Harvey

GeorgeBass (georgemarge1) said : #5

Can't find another page anywhere which duplicates this particular problem. Let's drop it.

Thanks for your efforts, George

arkmundi (rkerver) said : #6

I've struggled with this exact issue for a while, without any luck fixing it. Elsewhere we see: "That's the server's fault; the server said the file is application/octet-stream (meaning any generic binary file) instead of the more specific application/pdf. Just save the file as a PDF and view it locally." Calling Fidelity for support doesn't help as they only support Windows and Mac. I can change Firefox preferences for PDF files, but that's a bad solution, as what I choose to do is for all PDF files.

I hope this won't be dropped. In the case of files with the .pdf extension, no matter the application stream is said to be, we want the behaviour of opening the file with a "standard" viewer, Evince in the case of Ubuntu 8.04. Thanks!