Wubi sound problem

Asked by drifter on 2008-07-06

I have just installed wubi 8.04 as exe file piggy backing on XP. All music files and video files stored on my hard drives work very well in Totem Movie player,however there is no drum roll or ubuntu tune after boot or any sound when playing online video. In 'sound prefs' ubuntu does not detect on `autodetect' and I have set to `Multi Channel`in Music and Vid and ADC Capture/Standard PCM playback in sound playback . Sound Capture is set to Test Sound. Default mixer is set to ALSA mixer. Any other combos do not work at all. I thought it may have been F/Fox V3 because until I downed flashplayer I could not get video pictures online. Now I can but not sound.
I am not too techi so not really been able to progress. I tried reinstalling from the exe file but the result was the same. Can someone please help me. Wubi works really well on my Vista Laptop but not on my XP PC.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu evince Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2008-07-10
Last query:
2008-07-10
Last reply:
2008-07-06

Ubuntu 8.04 flash don't play audio
--------------------------------------

Please open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install libflashsupport

give your user password when requested, you don't see nothing when you type it, then press enter.

Then please edit /etc/firefox/firefoxrc:

sudo gedit /etc/firefox/firefoxrc

and modify or add the row:
FIREFOX_DSP="aoss"

Hope this helps

---------------------------------------------------------------------

Audio trouble with Ubuntu 8.04 some common checks

-- If you are using a laptop, your laptop may have a keyboard function to manipulate your sound.
   Check that. Your laptop may have a keyboard control to mute, increase and decrease sound.
-- Please check your sound devices volumes are to a high level double click on the top right loudspeaker icon you will see a mixer
-- Please make common test from menu System->Preferences->Sounds
   if you are using PulseAudio please read: http://www.pulseaudio.org/wiki/PerfectSetup or try if using ALSA things go better
-- If you have two audio cards - please disable the on board audio card using BIOS setting, please check with this terminal command:

   lspci | grep -i audio

-- Please be sure your pc are starting with the generic kernel press ESC at boot when you see the GRUB row then select the "kernel.... - generic" row
-- Please be sure all needed kernel modules are installed to make this check and install them:
  So open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install linux-ubuntu-modules-$(uname -r)

give your user password when requested, you don't see nothing when you type it, then press enter.

Then reboot your pc.

-- Be sure your user is member of audio group
Then open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo adduser $(who am i | cut -d" " -f 1) audio
sudo chmod 660 /dev/snd/*

give your user password when requested, you don't see nothing when you type it, then press enter.

-- Please try to watch what audio cards are detected on your system please type:
asoundconf list

if more than one sound cards is detected by your system to set the default soundcard

asoundconf set-default-card PARAMETER

change PARAMETER with the name of a one detected sound card

-- Please try to delete making a backup copy of this conf files
mv .asoundrc .asoundrc_old
mv .asoundrc.asoundconf .asoundrc.asoundconf.old
sudo mv /etc/asound.conf /etc/asound.conf.old

Please take a look at this http://ubuntuforums.org/showthread.php?t=205449

-- Please try to discover if there are any process they are keeping the /dev/dsp locked
ps -edalf | grep -i dsp

kill them using this command:

kill -9 number_of_pid

---------

If you microphone seems don't record your voice please open a terminal and type

alsamixer

and press tab to switch in view to [Capture] section, and then pressing space on mic and mic boost aid

If you are using Pulseaudio and you have some sound issue with sound apps please read http://www.pulseaudio.org/wiki/PerfectSetup
and this http://ubuntuforums.org/showthread.php?p=4928900

Hope this helps

drifter (universaldrifter) said : #2

Thanks. After following the above guide and the comrehensive sound guide you mentioned I have had no real luck. However, I have identified my sound cards,so far.

options snd-emu10k1 index=0
options snd-usb audio index=1
options snd-hda intel index=2

I do not know if the above is correct. They were in a different order when I started but at this point I was able to get all the sound tests operating with the sound parameters test BUT I also lost all video sound even in Totem!

Prior to me altering the order and I don,t know if the coding I did was correct they looked like this

 0 snd_hda_intel
 1 snd_usb_audio
 2 snd_emu10k1

At some stage I rebooted and got this

tc4mc@tc4mc-desktop:~$ lspci | grep -i audio
00:1d.0 Audio device: ALi Corporation High Definition Audio/AC'97 Host Controller (rev 02)
03:11.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
tc4mc@tc4mc-desktop:~$

I did get mic sound on the Skype phone at one point but that was about all.

At some point and I cannot remember at what stage I arrived at this:-

Usage:
asoundconf is-active
asoundconf get|delete PARAMETER
asoundconf set PARAMETER VALUE
asoundconf list

Convenience macro functions:
asoundconf set-default-card PARAMETER
asoundconf reset-default-card
asoundconf set-pulseaudio
asoundconf unset-pulseaudio

I have tried to get the SB Live card cmu10k1 up and running because I know that windows xp uses it but when I try to set the order and press enter in a terminal nothing happens.

Do you think I should uninstall the wubi exe and start all over because now when I enter asoundconf list in the terminal the SB Live card does not always show up, in fact
I have never seen 0 snd_hda_intel or 00:1d.0 Audio device: ALi Corporation High Definition Audio/AC'97 Host Controller (rev 02) show up until the last time I typed asoundconf into a terminal.

I am stuck on this I am sorry to say.

Would be pleased for any other ideas.

Regards to you, George (the drifter)

drifter (universaldrifter) said : #3

Also the last time I got this:- tc4mc@tc4mc-desktop:~$ asoundconf list
Names of available sound cards:
M5461
Phone

drifter (universaldrifter) said : #4

Thanks for all the advice but I solved the problem by uninstalling pulseaudio and installing esound via the Synaptic Package Manager. Now everything works including I player for all BBC programmes. Very pleased with this short way of getting all ubuntu sound working in wubi exe. One day I will have the courage to do a partition and reduce windows to a small black hole. My CPU performance is negligible and wubi is much faster.
I still wish to thank people like marcobra and other good people for their assistance and time they give to the linux/ubuntu enterprise.

drifter (universaldrifter) said : #5

Thanks marcobra, that solved my question.