evince fails to print password protected pdfs?

Asked by jplien on 2007-01-21

I'm trying to print a password protected pdf file using evince. There's no error message, but the job winds up just sitting in the print queue with Stopped state, and nothing is printed. I can work around the problem by using `pdftops -upw <pwd> <file>` The resulting .ps prints from evince with no problem. This may well be a CUPS problem. I'm not wise enough in the ways of CUPS to know where the boundary is.

A bit about my setup:

I'm running edgy. The evince and CUPS are the stock binary packages. The printer is shared by a remote samba machine. The problem is not on the remote configuration because checking the remote samba logs shows that no connection request has been received.

I'm running cups with loglevel 'debug'. Here's what I believe is the relevant section of cups error_log. Interestingly, the job keeps running even when pdftops fails.
------------------------------------------------------------------------------
D [20/Jan/2007:23:32:04 -0500] [Job 39] GhostScript extra search path ('GS_LIB'): /usr/share/cups/fonts
D [20/Jan/2007:23:32:04 -0500] [Job 39] Pondering option 'requesting-user-name=jplien'
D [20/Jan/2007:23:32:04 -0500] [Job 39] Unknown option requesting-user-name=jplien.
D [20/Jan/2007:23:32:04 -0500] [Job 39] Pondering option 'HalftoningAlgorithm=Accurate'
D [20/Jan/2007:23:32:04 -0500] [Job 39] Pondering option 'Density=3'
D [20/Jan/2007:23:32:04 -0500] [Job 39] Pondering option 'PageSize=Letter'
D [20/Jan/2007:23:32:04 -0500] [Job 39] Pondering option 'Manualfeed=Off'
D [20/Jan/2007:23:32:04 -0500] [Job 39] Pondering option 'Resolution=600x600dpi'
D [20/Jan/2007:23:32:04 -0500] [Job 39] Pondering option 'Economode=Off'
D [20/Jan/2007:23:32:04 -0500] [Job 39] Pondering option 'PageTimeout=15'
D [20/Jan/2007:23:32:04 -0500] [Job 39] Pondering option 'MediaType=Normal'
D [20/Jan/2007:23:32:04 -0500] [Job 39] Pondering option 'PowerSaving=On'
D [20/Jan/2007:23:32:04 -0500] [Job 39] Pondering option 'PowerSaveTime=5'
D [20/Jan/2007:23:32:04 -0500] [Job 39] Pondering option 'JamRecovery=Yes'
D [20/Jan/2007:23:32:04 -0500] [Job 39] Pondering option 'Altitude=Low'
D [20/Jan/2007:23:32:04 -0500] [Job 39] Pondering option 'AllowReprint=Yes'
D [20/Jan/2007:23:32:04 -0500] [Job 39] Pondering option 'job-uuid=urn:uuid:07684bc1-3522-368c-40b8-0a62c7cfba5e'
D [20/Jan/2007:23:32:04 -0500] [Job 39] Unknown option job-uuid=urn:uuid:07684bc1-3522-368c-40b8-0a62c7cfba5e.
D [20/Jan/2007:23:32:04 -0500] [Job 39]
D [20/Jan/2007:23:32:04 -0500] [Job 39] ================================================
D [20/Jan/2007:23:32:04 -0500] [Job 39]
D [20/Jan/2007:23:32:04 -0500] [Job 39] File: <STDIN>
D [20/Jan/2007:23:32:04 -0500] [Job 39]
D [20/Jan/2007:23:32:04 -0500] [Job 39] ================================================
D [20/Jan/2007:23:32:04 -0500] [Job 39]
D [20/Jan/2007:23:32:04 -0500] [Job 39] Reading PostScript input ...
D [20/Jan/2007:23:32:04 -0500] [Job 39] Error: Incorrect password
E [20/Jan/2007:23:32:04 -0500] [Job 39] pdftops_path exited with exit code 1
E [20/Jan/2007:23:32:04 -0500] PID 14565 (/usr/lib/cups/filter/pdftops) stopped with status 1!
E [20/Jan/2007:23:32:04 -0500] [Job 39] Empty print file!
E [20/Jan/2007:23:32:04 -0500] PID 14566 (/usr/lib/cups/filter/pstops) stopped with status 1!
D [20/Jan/2007:23:32:04 -0500] [Job 39]
D [20/Jan/2007:23:32:04 -0500] [Job 39] Job does not start with "%!", is it PostScript?
D [20/Jan/2007:23:32:04 -0500] [Job 39] Starting file converter
D [20/Jan/2007:23:32:04 -0500] [Job 39]

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu evince Edit question
Assignee:
No assignee Edit question
Last query:
2007-01-21
Last reply:
2007-01-31
jplien (jolien) said : #1

I just tried to print the same document using acroread, and it worked. To me, that indicates more strongly a problem with evince, or at least evince/CUPS interaction.

Can you help with this problem?

Provide an answer of your own, or ask jplien for more information if necessary.

To post a message you must log in.